On second reboot, getting message "Filesystem corruption has been detected!"

  • Device: Raspberry Pi 3 B+

    Version: LibreELEC-RPi2.arm-9.0.1.img


    TLDR: Copied an 8 GB image onto a 16 GB card causes error on second reboot.


    I have an 8 GB SD card that I set up and it works perfectly. No errors on reboot.


    I use Win32 Disk Imager to clone this 8 GB SD Card,

    and then write it to a new 16 GB one.


    On the initial boot, the 16 GB card works fine, but on the next restart, it gives the error message,

    Filesystem corruption has been detected!
    To prevent an automatic repair attempt continuing,
    press any key or power off your system within the next 120 seconds


    I tried some searching, and the suggestion was a bad SD card. However, I tried another one (also 16 GB) and the same issue.


    In addition, when I did a fresh install of LibreELEC on this 16 GB SD card, I could reboot with no problems at all.


    It's only when I copy an 8 GB image onto the larger 16 GB card, that this will happen.


    Does anyone know why this is happening?


    Thanks for any help!

  • The geometry of the partition scheme and filesystems on the card to not match the geometry of the card. Fix that (and resize the /storage partition) using Gparted from an Ubuntu LiveUSB (or similar) and you'll probably solve the issue.

  • isn't gonna be easier to backup old card and then restore on new 16GB ? If you got any files in other folders than snap taken just copy them over as well 😜

  • Yup, it's always easier (and considerably faster) to backup and restore the 1-2GB (average) of actual content to a freshly installed card than backup and restore 8GB of full card image. Users seem to like doing it the hard way though :)