RPi3B+ does not boot with latest image (9.0.1)

  • Hi,


    I just got a new RPi3B+ Model.


    I'm not able to install Libeelec 9.0.1 on that board. A SD Card with a 9.0.1 image does not boot. The SD card is fine,

    When turning on the power the green led is on for a very short time and then stays off.

    I tested the following:

    - Booting the same SD card on an older RPi2 model -> no problem.

    - I tried another distribution and installed the latest NOOBS 3.0 -> it works without issues.


    Any suggestions?

  • you can try rufus too, this is basically the gold standard at windows


    but this sounds like an dead sd card or an wrong image :)

  • Hi,

    * first of all, I'm not on Windows, I'm using Linux :-) and I'm using the image writer tool provided from Libreelec

    * downloaded the imgae twice -> same isue

    * tried the same card on another raspi -> works fine

    * tried another image (other than libreelec) with the same sd card on the new Raspi -> works perfect

    * tried another sd card with the image 9.0.1 image -> RPI3B+ does not boot

    * I'm suspecting the image write tool. Will do it manually next ... later this week, because I'm wasting my time on this ...


    I'll keep you informed

  • resolved :-D

    finally it turned out that the board had an issue. Ordered a new one everything works fine now.

    Thank you very much!