Hifiberry Digi+Pro 192kHz/24Bit Raspberry Pi3+ and LibreELEC9

  • Hallo,

    Sory vorab, das ich nicht auf Englisch schreibe, aber mein Englisch ist sehr schwach.

    Ich hoffe das mir trotzdem jemand von Euch helfen kann.

    Ich habe mir vor kurzem für meinen Rasprerry Pi3+ eine Soundkarte HiFiBerry Digi+ Pro (S/PDIF Chip unterstützt bis zu 192kHz/24bit, die Karte beinhaltet 2 Oszillatoren die optimale Taktfrequenzen für alle Abtastraten bieten) bestellt.

    Als Mediaplayer habe ich die neuste Version LibreElec 9 installiert. Als Audioausgang habe ich die ALSA: Hifiberry S/PDIF ausgewählt. Es funktioniert alles sehr gut so lange ich die Abtastrate in den Audiooptionen auf 44.1 kHz einstelle.

    Wenn ich aber die auf 48kHz oder höher z.B. 192kHz einstelle was die Hifiberry max. unterstüzt. werden alle Töne verlangsamt wiedergegeben. Musik ist langsamer. Stimmen beim Film sind tiefer als normal. Ich möchte gerne meine Musik möglich Verlustfrei und mit best mögliche Qualität FLAC 192/24 digital wiedergeben und das ist mit 44.1 nicht möglich.

    Bitte hilft mir mein Problem zu lösen.

    Danke im Voraus.

    Gruss Digiperry.

  • Das ist sehr seltsam. Hab' gerade mit meiner HifiBerry Digi Pro auf einem RPi3B+ unter LibreELEC 9.0.1 getestet und da hat alles einwandfrei funktioniert.


    Die einzigen Einstellungen die ich in den Audio settings geändert hatte waren das Audio output device auf "ALSA: snd_rpi_hifiberry_digi, S/PDIF" zu setzen und Limit sampling rate auf 96kHz (mehr schafft mein DAC nicht).


    Die "Output configuration" sollte auf "Optimized" stehen (das ist default), dann wird automatisch die richtige Samplerate (bis zum eingestellten Maximum) verwendet.


    Hast Du bei Dir irgendwellche Einstellungen geändert? Probier's am besten mal mit den default Settings (im Zweifelsfall einfach "Reset above settings to default" in den Einstellungen auswählen), in der config.txt muss für die Karte auch nichts eingetragen werden (die hat ein EEPROM drauf und wird damit automatisch erkannt/eingebunden).


    so long,


    Hias

  • Hallo Hias,

    danke für deine Antwort. Ich habe heute noch einmal LibreELEC 9.0.1 frisch aufgesetzt.

    Die Audioeinstellungen auf "ALSA: snd_rpi_hifiberry_digi, S/PDIF" gesetzt.

    Limit sampling rate auf 192kHz, "Optimized" und es funktioniert definitiv nicht.

    Die Audiodateien die mit 44.1 aufgenommen sind, werden ganz normal abgespielt. Alles gut.

    Dateien mit 48 bis 96kHZ Abtastrate werden langsamer wiedergegeben und Dateien mit 192kHz werden nur verzehrt und stotternd wiedergegeben. Eine Katastrophe. Ich habe ausserdem noch einen anderen RPi3B+ ausprobiert. Leider mit gleichen Ergebnis.

    Noch einmal vielen Dank für Deine Mühe.

    so long,

    Digiperry