LibreELEC installer not starting on Intel NUC7PJYH

  • I have an Intel NUC7PJYH and can't get the installer of LibreELEC to start. It stays stuck on the screen "Wait for installer to start or press [TAB] to switch options (live, run)..." System stops responding.

    I upgraded to the 0047 BIOS. It seems that all trouble have started when the Legacy Boot option is removed from the BIOS since 0042, and surprisingly it is also not possible to downgrade the BIOS to a version lower than the one where this option was removed.

    I tried several BIOS settings (enable or disable Secure Boot), and with my USB stick is nothing wrong because other systems (Zotac and my main PC) succesfully start the installer.

    Can someone help me? At this moment the NUC is just a brick in my desk...

  • I would try different USB drives anyway. Also, according to this page, Intel NUCs have a BIOS Recovery feature:

    BIOS Recovery Update Instructions for Intel® NUC

    Thank you for your tips. But I already tried different USB drives, also different SD-cards.

    I don't know what you mean with the BIOS Recovery Update Instructions.

    I can downgrade my BIOS to the version where Legacy Boot support was removed. Not further back. In others words, there is (according to Intel) no way to get the Legacy Boot option back.

  • When usb is in, have you rebooted , then enter bios and select it that way.?

    I had similar issue and was a bit fiddly to get installer to work. If you also want ir to work remember to activate in bios. (I didn’t realise this at first )

    I’m on bios 47 too as not long got my nuc , IR is working but range is poor.

    If you have any tips you can share or any bios settings you recommend would appreciate hearing from you .

    Good luck


  • Are you 100% certain that you flashed the Generic x86_x64 image to the USB using the tool and not the default device selection (RPI2-3 i.e. Raspberry Pi 2/3)?

  • Currently I run Kodi on Windows 10, and have the same issue with the range of the IR remote receiver.

    Therefor I opened the casing and noticed the IR receiver is located 3mm away from a small hole. I think if you make that hole bigger, the range would be better. The fact that you have this issue too, indicated that it has no point te return the NUC to switch it for a new one...

    I power on the device and press F10 to get into the Boot Menu. My USB device is shown there and I select it.

    The initialization of the installer starts, but gets stuck at a black screen saying: "Wait for installer to start or press [TAB]...".

    Pressing TAB doesn't work, the system hangs.

  • Are you 100% certain that you flashed the Generic x86_x64 image to the USB using the tool and not the default device selection (RPI2-3 i.e. Raspberry Pi 2/3)?

    I'm quite sure about that. The file is downloaded from the official LibreELEC website and its name is: LibreELEC-Generic.x86_64-9.0.0.img.gz

  • When the system stops responding, have you tried unplugging the keyboard and plugging it back in ? Maybe try another keyboard. I use a wireless keyboard on my two Intel NUC's when installing a fresh image.

    Also try an older version of LE to see if that works

  • When booting from the usb , rather than F10 , try F2 then select then usb .

    I had same issue and it worked that way. No idea if that was just luck though

  • Sniffer solution worked for me.

    Indeed selecting USB boot from F10 menu just freeze.

    Selecting USB boot from BIOS (F2) showed same menu under NUC logo , but typing "run" worked (after a freeze for 2-3 seconds).