Stock LibreELEC and retro gaming?

  • Thank you robmcc83, I really do appreciate!

    Based on your earlier hint I went and chosen a different path: installed AEL from a zip file and the desired emulators: snes9x2010 and pcsx-rearmed from standard LE/Kodi repos, then proceeded to define the launchers that called RetroPlayer (at least to my still shaky understanding that's AEL/RetroPlayer approach that none of your 3 alternatives cover).

    This worked like a charm for SNES, but for PSX not so much.

    I first had the issue where PSX roms would start (although complaining about missing bios) but the buttons would be dead, pads/joysticks funtional - can't even start a game without working buttons..

    I can't see where it tells me to upload the bioses, it's showing up briefly on a upper-right bubble when I start a rom, but it goes away before scrolling to show the whole message.

    I managed to place the bioses to ~/.kodi/addons/game.libretro.pcsx-rearmed/resources/system and the missing-bios message goes away, but the emulator now core-dumps :(

    In AEL configuration there's a "Check retroarch BIOSes" option that if you point your Retroarch system directory to the place you copied the BIOSes to it checks them and in my case the checksums for what's expecting for PSX (5500, 5501 and 5502) match.

    But this is what Retroarch would expect, and as far as I understand I'm using RetroPlayer...

    Am I too far in the woods?

    I'm not tied to the current approach, I simply chose it as it was looking like the minimal amount of fuss. The fact that it did work for SNES was encouraging..

    I'm going to look closely at your options and re-evaluate my approach, probably emulationstation seems best since I've seen it working with RetroPie...

  • Ive never used AEL someone else will have to help you with that I'm affraid, like I said in another post, I came from retropie that's why I chose the emulationstation approach as I know how it works.

    I have given more than enough information to get you playing games.

    If you already have roms following my instructions using emulationstation and retroarch you would be up and running within 10 minutes if you follow it correctly.

    It really is that simple.

    Example for running everything from SD card

    1. Install gamestarter repo

    2. Install retroarch and emulationstation

    3. Download libretro full cores from the configure menu of the retroarch addon

    4. Launch retroarch, exit then reboot

    5. Copy bios files to /storage/emulators/bios.

    6. Create a directory called psx in /storage/emulators/roms/

    7. Copy your psx games to that folder in iso or cue/bin format.

    8. Launch emulationstation pick your psx game you want to play and that's it your playing psx games.

    It's that easier, it only gets complicated when you want to customize things to your liking.


  • If your wanting to play psx games I would recommend not using Kodi retroplayer, it's not as good as retroarch at present.

  • Hi,

    I followed steps 1-8 (hopefully correctly), no joy.

    The only out of the ordinary thing was step 4 - once I got into retroarch gui my controller stopped working completely, and when trying my other input method (bluetooth mouse), only scroll wheel working - never mind, I connected a keyboard and hit escape to get out of retroarch gui.

    Now, when started emulationstation the psx game list has every game twice (presumably once for the cue file and the second for the bin/img)

    The bigger problem was that no game was launching - screen would turn black and come back to emulationstation psx game list.

    I tried going again in retroarch using keyboard and went to the online updater and downloaded a few random things - after that rebooted and started emulationstation again - this time the game would start, I could hear the game sounds but the screen remained black, with the exception of a frame counter on the lower left that was incrementing continuously (not a frames-per-second but a frames-since-starting-the-game thing)

    I couldn't get out of the game using the usual select+start or any other way, managed to kill emulationstation via ctrl-alt-del using keyboard.

    Note about the bioses: copied over all the files I had on RetroPie, don't know if the same ones are expected here. Maybe it's looking for slightly different names, or different there a way to check retroarch is finding the expected ones?

    (and yeah, running everyting from microsd card)

  • wait, one of the game starts, complains about the lack of bios and warns about compatibility issues - right, the sound is jagged is skips a lot.

    I can't use the controller, so I can't really play it.

    my bioses:

    buro:~ # md5sum emulators/bios/scph*

    924e392ed05558ffdb115408c263dccf emulators/bios/scph1001.bin

    6e3735ff4c7dc899ee98981385f6f3d0 emulators/bios/scph101.bin

    8dd7d5296a650fac7319bce665a6a53c emulators/bios/scph5500.bin

    490f666e1afb15b7362b406ed1cea246 emulators/bios/scph5501.bin

    32736f17079d0b2b7024407c39bd3050 emulators/bios/scph5502.bin

    1e68c231d0896b7eadcad1d7d8e76129 emulators/bios/scph7001.bin

    buro:~ #

  • And in regards to the bios, as long as you have not changed any configurations within retroarch you have placed them in the right place but you can check where retroarch is looking for them by looking for directories within the retroarch program once in directories the top one should be system/bios and it should point to /storage/emulators/bios.

  • Also it appears you bios file have wrong checksum as well.

    I don't think you have followed my instructions for installing retroarch properly at all.

    The black screen you get when trying to launch the game from retroarch means missing cores, which if you had followed today's earlier instructions you should have them.

    Also if you had followed today's earlier Instructions you would have obtained the correct bios versions for retroarch libreelec version as it says to check lakka bioses as that's what libreelec uses.

  • I have a cheap chinese PS3 knock off. It as A/B/X/Y instead of circle/triangle/cross/rectangle..

    I think it's correct: system_directory = "~/emulators/bios"

  • yeah, I have missed the lakka thing; it wasn't in your 8 step thing, though.

    Not that I'm complaining, let me have a go at it.

  • first things first...can you access your system from another pc with preferabbly Notepad ++

    Yes, I can, over ssh. My desktop is a linux as well, so no notepad++, but I can use vi

  • Go to es_systems.cfg in emulation station addon data folder and edit the extension line for each emulator and leave only the extension you have to run the game like.nes,.snes etc

    sound crackiling go to retroarch.cfg and adjust line 2908 to something like 29.97

    that count on screen you can disable it from retroarch settings

    controller you have to bind from retroarch

  • regarding extension on emulation station that is to solve your problem of ES showing double files for each game foe ex in PSX you have bin ,cue remove bin as extension to show and leave only .cue

  • regarding controller, retroarch gives me this:

    es_systems.cfg is clear, but retroarch.cfg line 2908 is:

    video_message_pos_y = "0.050000"

    ..there's probably an "audio*" line I need to edit, right?