LibreELEC 9, odroid-c2: device does not get powered on by TV with CEC

  • I manually updated to 9.0 by copying the image file LibreELEC-Odroid_C2.arm-9.0.0.img.gz to /storage/.update and rebooting, as per Update LibreELEC []. With 9.0.0 my odroid-c2 is not powered on via CEC when the TV is powered on. I had to unplug the odroid's power supply and plug it back in to get the odroid to boot up.

    I downgraded to 8.2.5 by copying LibreELEC-Odroid_C2.aarch64-8.2.5.img.gz to /storage/.update and creating /storage/.update/.nocompat. I then shutdown the odroid, unplugged the power supply, and plugged it back in. LibreELEC was downgraded to 8.2.5. I shut down the odroid which turned the TV off, as it should have. When I turned the TV back on the odroid powered up.

    Edit: The same thing was reported at Odroid_C2 8.90.006 no CEC Power on by connected TV - LibreELEC Forum with a beta version.

  • I manually upgraded again to LibreELEC 9.0.0 (SHA256: 1dfe766d8a2ec8b2053f2524a80db77b25026aa283409e3d86c8717befcaf5f3). I ran

    systemctl stop kodi
    mv .kodi kodi.old

    The odroid seemed to power off instead of reboot. I waited for a few minutes in case something was happening even though I saw "no signal" on my TV. After around 5 minutes I unplugged the odroid's power and plugged it back in. LibreELEC booted and I was prompted to set up my device. I configured the CEC adapter and shutdown Kodi from the interface. I turned on the TV. My HDMI input was unchanged (HDMI 3 - Kodi). I switched to "live TV" and back to HDMI 3: the odroid did not power on.

    I cycled the power on the odroid again to get it to boot. I logged in via SSH and typed "reboot". I had the same behaviour as before; the odroid seemed to be off and didn't actually reboot.

    I tried the current nightly build, LibreELEC-Odroid_C2.arm-9.0-nightly-20190201-974f4cb.img.gz, moved .kodi out of the way and typed "reboot" within SSH. This time the odroid did reboot. I turned the odroid off via Kodi's interface. My TV turned off. I powered the TV back on and this was just like before: the odroid did not power on.

    I went back to 8.2.5 (SHA256: 9cc3cb2cb0481753af9b5db105e1a853673150e08fc51a13904fef4ef0798c5d) and CEC is again working with my LG TV and my C2.

    debug logs from the nightly build: Debian Pastezone

  • Same problem. What are the prospects for a fix? I don't know how well supported this board is with LIbreELEC.

  • Someone who reported having the same problems (on the odroid forums) says it works with coreelec 9.0.1. (LibreELEC 9, odroid-c2: device does not get powered on by TV with CEC - ODROID)

    Switched to coreelec 9.0.1 simply by putting the coreelec update into the Update folder an then did a reboot.

    All Problems gone,

    CEC Poweron works

    no flashing white bars on the right side of the screen anymore

    no sudden stops on live tv or recordings

    no skip problems anymore

    really satisfied :)

    2x Odroid C2 - 64GB eMMC

  • I also switched to CoreElec 9.0.1 and have working CEC. Everything else seems to work too. Excellent!

    I was not able to upgrade by just putting the update in the .update folder. I rebooted and the update process seemed to proceed. There was an error, however, and my odroid failed to boot, so I had to do a full installation and that worked. I restored the backup I created of the .kodi directory and my library was intact. I don't know if I'm going to run into problems in the future by doing it this way but we'll see.

    Hopefully this gets fixed in libreelec but it seems I'm now a coreelec user...