Can't play or index my movies from NAS Harddrive

  • I have a RaspberryPi 3+ with OpenElec V7.0.1 (KODI V16.1) and it just works perfectly. But I would like to upgrade to a newer version of KODI. But all the versions I have tried - LibreELEC v8.25 + v8.95 or OSMC v2018.10.1 + v2018.12.1 - I can't get to index my movies / series or play them. I can find the folders where they are and see the files - they are on a NAS hard drive, but it won't play them. I have tried to install KODI 18 on my Windows computer and it works perfectly.

    I've tried copying some movies into the download folder on RaspberryPi and they can be found and played well ....

    Does anyone have an idea of what I can do?

  • What NAS, smb or nfs?


    Does the nas need a password?


    post exactly, how you are adding the movies.

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • It's smb

    No password

    Enter Files Section
    Add Videos
    Browse
    Add Network location - Protocol (SMB)
    Server name - Here I enter the name of my NAS (Serie-01)
    Then I pick my NAS from the list (smb://serie-01/)
    Then I pick the folder (Video/-+-serier-+-) and press OK
    The directory contains - TV Shows
    Choose information provider - Local information only

    Then it just scans through the folders and then no more happens. When I do the same on my PC with KODI 18.0-RC3 it works fine.

  • By default, Kodi 18 uses SMBv2 and up (thanks to Microsoft).

    Network browsing was disabled, and full credentials (including a password) for preferably a non-admin user is required.

  • So, what you need to do is, add network location.. select smb, then add ip address, add user name & password, then SAVE


    then add, use the network location you have just created. you should then see the movie files

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 H96 Pro (Coreelec), Fire TV 4K Stick (Bedroom)

    Synology DS414 Plex Pass

    :)

  • So, what you need to do is, add network location.. select smb, then add ip address, add user name & password, then SAVE


    then add, use the network location you have just created. you should then see the movie files

    I dont have a username and password on my NAS it's public. But now I have setup my NAS with a username and password and done what you said. But KODI still can't index my movies. If I go into the movie folder, I can see the files, but I can't run them.

  • I dont have a username and password on my NAS it's public.

    A public NAS..? So literally everyone on this planet can access your NAS device? You are a very generous man, but with a very insecure network setup.


    But now I have setup my NAS with a username and password and done what you said. But KODI still can't index my movies. If I go into the movie folder, I can see the files, but I can't run them.

    Indexing is something else than accessing. If you can access the files by Kodi, then the network connection itself is working. After that, you may have to double-check which user/file rights are active. Read-only, wrong user.. something must be off.

  • A public NAS..? So literally everyone on this planet can access your NAS device? You are a very generous man, but with a very insecure network setup.

    Maybe I should consider getting a password :-)


    Indexing is something else than accessing. If you can access the files by Kodi, then the network connection itself is working. After that, you may have to double-check which user/file rights are active. Read-only, wrong user.. something must be off.

    I can access the files when I use KODI v18.0-RC3 on my Windows 7 PC and on a RaspberryPi with OpenElec V7.0.1 (KODI v16.1) so i don't think its my NAS that is the problem.