Problem with EPG on TVHEADEND

  • HI all

    I have been running Libreelec with TVHEADEND for 2 months now without change anything. Suddenly I dont have any EPG data, using internal XMLTV. When I Re-run the internal EPG grabbers button I get the following in the debug window:


    2019-01-12 08:25:36.623 spawn: Executing "/storage/.kodi/addons/service.tvheadend42/bin/tv_grab_file"

    2019-01-12 08:25:37.147 xmltv: /storage/.kodi/addons/service.tvheadend42/bin/tv_grab_file: htsmsg_xml_deserialize error Expected ' or " before attribute value

    2019-01-12 08:25:37.147 xmltv: /storage/.kodi/addons/service.tvheadend42/bin/tv_grab_file: grab returned no data


    Whats wrong?

  • Something is wrong with your XML file. The syntax isn't correct. You need open the XML in notepad++ or any other that can verify.


    Some channel name or something hasn't been written correctly

  • Do I realy need to reinstall everything to get it to work again?? Someone must have an idea?

  • no you don't. You cant possibly be using the same xml file that you were when you set it up. How else would you be getting updates. Perhaps post your xml file.

  • sorry again, but is it this one you mean? :

    ./storage/.kodi/userdata/addon_data/service.tvheadend42/settings.xml

  • ok, here it is:

    <settings>

    <setting id="AVM_DEVICE" value="AVM_Repeater" />

    <setting id="AVM_ETH" value="eth0" />

    <setting id="AVM_IP1" value="192.168.178.201" />

    <setting id="AVM_IP2" value="192.168.178.202" />

    <setting id="AVM_IP3" value="192.168.178.203" />

    <setting id="AVM_IP4" value="192.168.178.204" />

    <setting id="AVM_ROUTER_FAKE_IP" value="192.168.178.254" />

    <setting id="AVM_ROUTER_IP" value="192.168.178.2" />

    <setting id="AVM_SATIP_SERVER" value="false" />

    <setting id="CUSTOM_ARGS" value="" />

    <setting id="CUSTOM_START" value="false" />

    <setting id="DEBUG_LOG" value="false" />

    <setting id="DEBUG_LOG_PATH" value="/storage/.kodi/userdata/addon_data/service.tvheadend42/debug.txt" />

    <setting id="DEBUG_LOG_TRACE_1" value="NONE" />

    <setting id="DEBUG_LOG_TRACE_2" value="NONE" />

    <setting id="DEBUG_LOG_TRACE_3" value="NONE" />

    <setting id="DEBUG_LOG_TRACE_4" value="NONE" />

    <setting id="DEBUG_LOG_TRACE_5" value="NONE" />

    <setting id="NUM_ADAPTERS" value="1" />

    <setting id="PRELOAD_CAPMT_CA" value="false" />

    <setting id="REMOVE_MODULES" value="" />

    <setting id="WAIT_FOR_FEINIT" value="false" />

    <setting id="WORKAROUND_SLEEP" value="false" />

    <setting id="WORKAROUND_SLEEP_TIME" value="1" />

    <setting id="XMLTV_LOCATION_FILE" value="" />

    <setting id="XMLTV_LOCATION_SCRIPT" value="" />

    <setting id="XMLTV_LOCATION_WEB" value="http://estiptv.site/epg/SE_guide.xml" />

    <setting id="XMLTV_TYPE" value="WEB" />

    </settings>

    Strange, it looks like it using an old XMLsite, se_guide.xml. When I configured XMLTV I told it to use channels-sweden.xml. And that link cannot be found. Could it be that?

    And I dont have anything at 192.168.178.201-204. Dont have that network.

    Edited once, last by Nybbe ().

  • That's because se_guide doesn't contain any epg data, it is just a bunch of channels.


    the file needs to be of this format for xmltv:


  • Problem solved, the Estiptv.site site has closed down so I used another XML-file provider from my IPTV provider. And no, mfizz, I used a new file with the channel, no data. Dont know how it works but it does.

    Thanks all!