Libreelec freezes on recent 8.2 and 9.0 branches

  • I've been using Libreelec on a RPi2 for a long time and it always was rock solid. In 8.2.x until 8.2.5 it started freezing often. The whole device hangs and has to be plugged out before restarting and cannot be accesses over SSH. What I already did:


    - Upgrade to 9.0: same issue

    - Replace the RPi2 with an RPi3 and new power supply: same

    - Clean install on a new SD card in the new RPi3 and no add-ons: same

    - Ran memtest: no faults


    There is nothing about the crash in the logs, I think the devices freezes before anything useful is written.


    Actions that trigger it are library updates, forwarding movies and after a plugin is installed, playing internet radio. The system does not crash on playing movies unless forwarding or rewinding, it doesn't crash on youtube streams or if you let it run without actions.


    Temperature is below 60 degrees under load.


    Log file: http://ix.io/1xcz

    No crash log is there.


    EDIT: My files are accessed over SMB stored on a NAS, it mostly affects these but the radio streams on listenliveeu are affected too

  • Code
    1. 11:37:02.445 T:1936896672 NOTICE: Disabled debug logging due to GUI setting. Level 0.


    Well, there is not much to see in that log file. Although, also debugging wasn't enabled.


    It kind of stops when network access is going wrong. A faulty network chip perhaps? Even a RPi can break down.

    Is the network up in the first place (using "Wait for network")? Try to put the network cable in a different port of the router. Or are you using wifi?

  • Hi Klojum

    I will try to get a debug log (annoying that it keeps the overlay on screen when that is on).


    I'm using wired network, but the chip being broken should not have followed on the brand new Pi3. Also, the Pi does not respond through CEC anymore either.