Intel GMA 3xxx - jerking video at playing in 8.90.x

  • I'm having a problem with the latest build of Libreelec (8.90 Alpha - all versions) - the jerking/stuttering video while playing (Intel G31 chipset with CPU E8400).

    In 8.2.5 (any 8.x.x) it's all OK.

    I tried to change all the choices that could affect synchronization in some way, but without success. In short, playback is not smooth. However, CPU power is more than sufficient (usage < 50%).

    In the upcoming build 9.0 something had to be changed to destroy the smoothness of playback.


    Any advice? Did I overlook something? I am doing something wrong?


    I very much appreciate the work of developers.

    I always thought Libreec was a good way to use older hardware, but these issues change my mind.

  • Just a wild guess. Maybe the Intel G31 Integrated Graphics lost full support in the 8.90 Alpha versions. After all, it's nearly 10 years old.

  • Check and see if the source content is interlaced or not. This micro-stuttering on some platforms especially with interlaced content is being discussed within the Kodi forums.

  • I am not watching interlaced videos.

    But I have new findings. When I enable lower display resolutions, set the lower the resolution, the smoother the playing of video is.

    So when I play a full HD stream (1920x1080 px) at the resolution of 640x480x60Hz for example, it is practically ideal. (smooth playing without stuttering).

    Did not a developer place a automatic image resize procedure (which cripples the IGP) or something strange in the process of filter queue (in contrast to 8.x.x)?