Intel true 10bits/HEVC/HDR support... ?

  • I googled the picture of the Brix Gemini Lake mainboard. For some bizarre reason, it has PTN3366 HDMI level shifter (a chip near the HDMI port).

    That chip is not HDMI 2.0 compliant and probably causing these issues.

    I think I got a logfile, if you could have a look.

    Ubuntu Pastebin

  • I see nothing useful in that log file.

    Does it lose the signal after any resolution change? 1080p modes too?

  • With Display Resolution set to 3840x2160, if I try to change Refresh Rate in settings, it goes black until it reverts back, since I can't tell it to accept changes. If I set Display Resolution to 1920x1080, then I can change refresh rate to 23.98 and DVDs and blu-rays appear to work with the TV staying in 1080/24. 4K movies remain blacked out.

  • 00:02.0 0300: 8086:3185 (rev 03) (prog-if 00 [VGA controller])

    DeviceName: Onboard - Video

    Subsystem: 1458:1000

    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+

    Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-

    Latency: 0, Cache Line Size: 64 bytes

    Interrupt: pin A routed to IRQ 122

    Region 0: Memory at a0000000 (64-bit, non-prefetchable) [size=16M]

    Region 2: Memory at 90000000 (64-bit, prefetchable) [size=256M]

    Region 4: I/O ports at f000 [size=64]

    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]

    Capabilities: [40] Vendor Specific Information: Len=0c <?>

    Capabilities: [70] Express (v2) Root Complex Integrated Endpoint, MSI 00

    DevCap: MaxPayload 128 bytes, PhantFunc 0

    ExtTag- RBE+

    DevCtl: CorrErr- NonFatalErr- FatalErr- UnsupReq-

    RlxdOrd- ExtTag- PhantFunc- AuxPwr- NoSnoop-

    MaxPayload 128 bytes, MaxReadReq 128 bytes

    DevSta: CorrErr- NonFatalErr- FatalErr- UnsupReq- AuxPwr- TransPend-

    DevCap2: Completion Timeout: Not Supported, TimeoutDis-, LTR-, OBFF Not Supported

    AtomicOpsCap: 32bit- 64bit- 128bitCAS-

    DevCtl2: Completion Timeout: 50us to 50ms, TimeoutDis-, LTR-, OBFF Disabled

    AtomicOpsCtl: ReqEn-

    Capabilities: [ac] MSI: Enable+ Count=1/1 Maskable- 64bit-

    Address: fee01004 Data: 4021

    Capabilities: [d0] Power Management version 2

    Flags: PMEClk- DSI+ D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)

    Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-

    Capabilities: [100 v1] Process Address Space ID (PASID)

    PASIDCap: Exec- Priv-, Max PASID Width: 14

    PASIDCtl: Enable- Exec- Priv-

    Capabilities: [200 v1] Address Translation Service (ATS)

    ATSCap: Invalidate Queue Depth: 00

    ATSCtl: Enable-, Smallest Translation Unit: 00

    Capabilities: [300 v1] Page Request Interface (PRI)

    PRICtl: Enable- Reset-

    PRISta: RF- UPRGI- Stopped+

    Page Request Capacity: 00008000, Page Request Allocation: 00000000

    Kernel driver in use: i915

  • There was a linux commit that fixed a similar issue on some Gemini Lake boards with ITE66317 HDMI retimer.

    I will modify that patch so it would work on Gigabyte Brix. I will post a build for you to test in an hour or so.

  • Here is the logfile. I tried changing refresh rate on Display setting first (didn't work, let it revert back to 60), then tried playing a 4K UHD movie. That one went to No Signal. After stopping it, I had to unplug and replug the HDMI cable to get it back. Then I tried a DVD, which went to No Signal, though when I stopped it, the movie wall came back.

    Ubuntu Pastebin

  • Yes. You can use a build from post #387.


    How does it work is it auto switching to HDR?

    Or are there settings in kodi to toggle HDR?

    And is HD-AUDIO (trueHD, Master audio ) passtrough also working?

    What are the recommended setting to get HDR to work properly?

  • DRM PRIME decoder must be enabled.

    I don't use audio passthrough. Some people reported glitches with HD-AUDIO (same as with the official builds).

  • DRM PRIME decoder must be enabled.

    I don't use audio passthrough. Some people reported glitches with HD-AUDIO (same as with the official builds).

    Great thanks i'll give it a try.