u-boot corrupted - Boot only via SD. S905x 8gb/1gb

  • ...


    What was wrong?


    ...

    I have already given you the answer to this question. You need a DTB file with "nand“ suffix, otherwise the integrated Nand memory can not be recognized.

  • I tried all the DTB files with the nand suffix and renamed as dtb.img, but I'm not able to "Install to internal"


    Now the NAND is a Essencore 13t-8gq8t2h5tarc


    I think this is important to know.


    At the end I can flash the unit with the stock firmware.

    I can boot librerlec from SD.

    I cannot install libreelec to the internal memory


    Anything else will corrupt the image.

  • Unless your box has particularly crap components a decent SD card will give good LE performance.

  • Добрый день! Тот же самый аппарат доступен с теми же проблемами. Я не могу найти прошивку. До 7% и конец. Я прошу вас поделиться ссылкой на рабочую прошивку для этого устройства. И, если возможно, поделитесь своим опытом установки прошивки. Заранее спасибо.

    Удачи брат!

  • Good day! There is the same TV android with the same problems. I can not find the firmware. Up to 7% and the end. I ask you to share a link to the working firmware for this device. And if possible, share your experience in installing the firmware. Thanks in advance.

    Good luck brother!

  • Moreover, there are 2 firmwares available that flash it to 100% on this TV box, but in the first case, when connected to TV, the logo does not go further, when loaded with the button pressed under (AV), a green recovery is displayed on which there is no possibility to mount partitions . On the second firmware also hangs on the logo, but it is possible to go to TWRP. In TWRP also can not mount partitions. I ask for help in solving experts.


    There is the same device in working condition from which I made a backup through the TWRP program, but when transferring to a non-working device, it reports that the internal memory is "0". This cannot be, since the firmware through the computer becomes. I'm at a loss ...

  • KE, I have a unit with exactly the same problem. I am glad I found your posts--I thought I was going crazy! Would you be able to share the IMG you received from the manufacturer? I want to bring my unit back from dead. Thank you in advance! :)

  • Hi KernelPanic! You saved my life with the firmware!

    Do you found any TWRP working with that?

    Can you tell me the contact of the manufacture to get the latest update of the firmware? (I have some boxes with p281-userdebug 7.1.2 NGH47L 20180416 and another with p281-userdebug 7.1.2 NGH47L 20180707, the latest is best)

    Thanks!

  • Please try this img.


    Unzip and use USB Burning Tool


    https://drive.google.com/open?id=10h1vuoxn-vupfebj1xsusjojsww7dxz7

    So this img is the ONLY one to work with my MXQ Pro 4k... i have the s905x 20170907 with an essencore drive.... it completed its burn... now to test


    This may hold the key as to why i have not found anything else that works with this box.


    Edit: after burning the red light stays on and i cant boot, or maybe i am not waiting long enough.


    I also can not get the device to be reconized by the pc until i reset the flash on pin 7-8 (idk for sure i ran a wire along it to short each set one at a time.


    I can get it to burn again, waiting for that to complete. This box seems to be a pain in the ass for a number of people so hopefully i can figure out whats going on and maybe be able to suppy a working img.


    Another edit: I have found something interesting. If i burn this image to my box, change the image in the tool, do not disconnect power but unplug usb and replug it, i am able to burn the stock rom i found. I was not able to do this prior, so this img seems to open the write protect somehow.


    I am also not erasing the bootloader either, but we will see what happens.


    Thank you for making this or providing it.


    Again another edit: So far i have tried to burn 4 imgs after burning the one you made with success. some the red light stays, some i get signal on hdmi but just black display, it is not entering recovery on any of them. I am thinking more digging to find the correct firmware for this stupid tv box. i am sure i can find a combination of parts to make this work... ugh...


    Last night I found that my box can in fact boot libreelec 8.2. Success .... Sort of.


    I also found that you can boot from the SD, as mentioned all over, get to recovery, but have no read write access to eMMC. Why can I even burn the black and red image to the device, but it can't boot? More digging at an old problem.