audio playback issues on rpi3b+

  • Hi there

    Leia is causing some trouble when playing back audio files. What's happening is the following:

    When I start playing a file, the first fraction of a second is played. then playback is interrupted for maybe half a second, then it restarts and keeps playing normally.

    In my tests this did not happen always, but most of the time. I observed it both on .flac and .mp3 files.

    I have a hifiberry dac+ installed. However there is no difference when selecting hdmi output and playing throug the TV speakers instead.

    This happend already in Leia alpha (I reported it to irc but never got a reply) as well as in beta 1 and now in beta 2.

    Video Playback is working fine, both audio and video.

    Hardware: Raspberry Pi 3 Model B+

    Software: Libreelec git 442e2de built as:
    PROJECT=RPi DEVICE=RPi2 ARCH=arm make image




    If anything else is needed, just let me know!:)


  • Can you confirm the same issue occurs on LE 8.90.005

    No, that was too fast. Can't confirm at this time. Will test further and report!

    Yes, just confirmed it. I used a new sd and installed the image I downloaded from the homepage.

  • Ok. Now I can confirm: Yes, it happens also in 8.90.005.

    The thing is though:

    This happens when starting playback though the yatse remote through the 'files' setion. It does not happen when I use yatse's remote to browse through the kodi gui!

    I have been able to reproduce this many times using the same file!


    kodi.log with debug

  • I'm guessing there was no issue on 8.2

    Hmm. There is nothing obvious in the logs.

    Can you try again with a normal keyboard/mouse as I have a feeling that "yatse" might be causing the problem - at least it will eliminate one area.

    I'd also try a different file with a shorter path name and without "special" characters - just in case.

  • The difference is whether I use yatse's 'files' section to start playback (problem) or kodi's gui (no problem).

    In the latter case it does not matter whether I use yatse or the normal keyboard (which I have also testet). Both work just fine.

    So it seems when starting playback through the 'files' mechanism, something else happens on the libreelec side compared to using the kodi gui.

    I'm guessing there was no issue on 8.2

    I'm not so sure about this. Should I check?

    Another thing, I do not get the described behaviour when using a different distro (OpenADK) with leia. This would indicate there is nothing fundamentally wrong with yatse, the issue seems to be how yatse's signals are treated.

  • This is not happening in 8.2.5. Tested and could not reproduce!

    Your link: yes, it may well be related. Then it would probably be a kodi issue?

  • OK thanks - seems to be a conflict between Yatse and Kodi.

    Not really anything LE can do about it - yet.

    We're still alpha, so just wait a while

  • Hi there

    Tried again with the LE beta (ce07c47). Still the same...

    Edit: Did some more testing. Using kore instead of yatse shows the same behaviour in file mode...

  • Hi

    So this bug is still present in the current 9.2 beta.

    Basically, audio playback through remote has been broken across more than an entire major version cycle.

    Also, it seems to be not an rpi problem but happening across platforms (can reproduce on my nvidia shield).

    Any chance to get some motivated devs to fix this/how?