[Solved] No output when more than 2 audio channels

  • I run kodi on a Intel Nuc.

    The audio output is configured so kodi decodes audio streams and output 4.1 channels, through the HDMI output. All was working fine until last week. I shutdown everything before I left, and when I returned and restarted everything, no audio at all.

    I checked to see if it was an amplifier problem, but, no, it was kodi not sending anything. I upgraded LibreElec (8.2.4 -> 8.2.5), and after reboot, audio worked again. I though a param was lost during the shutdown or so...

    But last night, I tried to play a multi-channel movie (DTS): no sound! If I configure the output to limit to 2 channels, it works. But as soon as I have more than 2 channels, nothing. I tried to re-enable the audio passthru: same, no audio when playing the movie (I see the PCM label blinking on the amplifier, saying there is a stream missing or problem). But all works fine on music, or with UI sounds (2 channels only). I tried to change a lot of params, without any success.

    Any idea what happens? Software? Hardware? I'm puzzled...

    Thanks,


    Frédéric

  • I would first check all your connections and if they look OK, change the HDMI cable.


    If that doesn't help post a full debug log as explained in my signature and also the output of dmesg | paste

    It "might" show up a problem. But it sounds more like H/W than S/W.


    You could also try the alpha release - LE9 8.90.003 if all else fails.

  • Ok, so I dug deeper on the hardware... and found the problem!


    In fact, there where 2 issues : the hdmi input I was using on the amplifier does not work well anymore, *and* the HDMI cable was also faulty :o( So, my initial tests with this cable didn't show that only 1 HDMI input was buggy.


    Very strange all this occurred after a shutdown. But, well, it did!


    Again, thanks for your help!

  • Iridium

    Changed the title of the thread from “No output when more than 2 audio channels” to “[Solved] No output when more than 2 audio channels”.