LibreELEC 8.x images for additional dvb drivers

  • Hi CvH,


    I use your images for some years. becoz of the great stability
    But i have a question.


    Is it possible to change from driver pack without using the gui interface
    in the openelec version you could change a txt file the driver pack.

    • Official Post


    Dvr is only detecting frontend 0 which only have dvbt, frontend 1


    try with new image


    Is this also warned drivers to wetek compilation?


    sorry I don't understand you


    Is it possible to change from driver pack without using the gui interface


    yes just change /storage/downloads/dvb-drivers.txt with for example 4.4.13-crazycat from here source of the script


    but you have to watch that you don't add an line ending to the file -> I think you can't do it with nano - just use
    # echo 4.4.13-crazycat > /storage/downloads/dvb-drivers.txt



    New version is ready


    but I haven't tried it yet Index of /LibreELEC/7.0_Jarvis/


    7.0.2-dvb-drivers-1.5
    - added RPi 1 image
    - ljalves is back and replace ljalves-cc - you have to reset the setting !
    - updated all other images

  • None of the drivers works with my TBS-USB-Tuner. Neither the OSS nor the official TBS....


    €dit: The DVB-C drivers work somehow, but I can only see the DVB-S2 input of my TBS 5520. The DVB-C and DVB-T2 inputs are missing. With the OSS drivers i could see all three inputs in 7.0.1...

    Edited once, last by Yoshi ().

  • I'll see what I can do later. I hoped someone else with a TBS card would have tried until now ;) Just to be sure: is it possible to downgrade to 7.0.1 or do I need to reinstall everything?


    €dit: downgrade works, just tried it ;) Right now I can only ssh into my box so I can't enable debug-logging (advancedsettings.xml doesn't work, log folders are empty?!). With 7.0.1 the tuners are called Availink AVL 6882 DVB-S #0 & DVB-C #0 & DVB-T #0. Device-ID with 'lsusb' is 734c:5520.


    With 7.0.2 the device gets listed with lsusb but I'm sure no drivers are loaded. This is all I can say right now without the logs...

    Edited once, last by Yoshi ().


  • yes just change /storage/downloads/dvb-drivers.txt with for example 4.4.13-crazycat from here source of the script


    but you have to watch that you don't add an line ending to the file -> I think you can't do it with nano - just use
    # echo 4.4.13-crazycat > /storage/downloads/dvb-drivers.txt


    Thanks CVH

    Edited once, last by CvH ().

  • Anyone elese still getting the update avalible even after installing this version? First time Ive ever seen this with a CvH build. Double checked and im defo on 7.0.2 but still being told that an update is avaliable.

  • i know you dont support auto-update but I use it to let me know that a new verion of libreelec is out. Normally I`ll install your build and update it and the notice goes away, this latest version is the first time ive ever had it tell me there is an update even when its been updated.

  • CvH , I have begun with ljalves the open source driver for TBS5990.


    Seems it may have the same problems for me decoding dvbs2 muxes off Asiasat 5. Just the picture quality takes a bit of a kick in the guts on some HD channels.


    Initially we tested it on Apstar 7 (different satellite) & I was surprised it ran every MPEG 4 HD channel (one for 3 hours) with not a hint of a glitch on ljalves first attempt at hacking up working open source driver.


    Would there be something missing decoder wise in the original build of the media_build / or even something missing from tvheadend? I have tried your OpenELEC tbs's linux drivers for TBS5990 and these problematic (error prone) channels actually work well. This is why I ask you is something missing ie. up to date codec's etc ? (im not good with this stuff)


    Scratching my head because crazycat/smallint already got an open source driver fully working on both tuner's and I gave up because I had the above same problems.


    My question is , could this driver issue actually be tvheadend or codec/decoder problem


    Typically this is what I see from tvheadend just now
    2016-07-01 14:21:06.256 TS: Asiasat 5/4040H/C Music TV: H264 @ #3031 Continuity counter error (total 1)
    2016-07-01 14:21:06.312 TS: Asiasat 5/4040H/C Music TV: MPEG2AUDIO @ #3032 Continuity counter error (total 1)
    2016-07-01 14:21:10.079 TS: Asiasat 5/4040H/C Music TV Transport error indicator (total 1)
    2016-07-01 14:21:16.270 TS: Asiasat 5/4040H/C Music TV: H264 @ #3031 Continuity counter error (total 5530)
    2016-07-01 14:21:16.382 TS: Asiasat 5/4040H/C Music TV: MPEG2AUDIO @ #3032 Continuity counter error (total 303)
    2016-07-01 14:21:26.300 TS: Asiasat 5/4040H/C Music TV: H264 @ #3031 Continuity counter error (total 11070)
    2016-07-01 14:21:26.356 TS: Asiasat 5/4040H/C Music TV: MPEG2AUDIO @ #3032 Continuity counter error (total 595)


    this is too many errors & doesn't play at all and happens to few other channels as well on this SAT.


    But (scratch head again) plays in DVBViewer on Windows machine absolutely no problem at all, on simple TP parameters from lyngsat, same dish alignment.
    Also, with same hacked up linux driver by ljalves on same box (unfinished still testing) plays all MPEG 4 HD mux on Apstar 7 friggin flawlessly. (3 hours tested)


    something to do with error handling in tvheadend ? pretty sure your OpenElec version of tvheadend played this correctly w/ tbs's drivers ? Maybe TBS5990 open source is finished but just problem with tvheadend. Maybe you could try crazycats build


  • Does the remotes work with all of the above drivers ? if used


    ljalves is using my tbs5990 on machien i set up to create driver. He's a bit busy though it seems. done initial testing on Tuner A.


    Still a little far from finished. test Tuner B and then perhaps I can get him to fix my little prob with errors on. Could be timings or something i was told

  • release what ? just another fork of ljalves/linux_media


    this


    crazycat , on looking @ previous attempts & learning a few things testing ljalves half done tbs5990 driver on different SAT from which we tested,


    Apstar 7 the ljalves driver was playing MPEG 4 HD channels without any issue. (8mb/s max tried/available 3 hours running no problem)
    Apstar 7 scanned normal dvbs & dvb-s2 mux MPEG 4 HD I had not one issue at all on any channel/s within tvheadend


    With C MUSIC & FUEL TV & etc on Asiasat 5 it only seems to be able to push out 2mb/s on 1080p channels which is not enough and full of errors obviously
    it looks as if the problems I was having may be error handling (?).... or ability to deal with error prone channel/mux
    is this performed by driver or by software decoding, if it is then may be driver is ok