LAN internet not connecteted. help_?

  • hi, my libre instal on PC cpu AMD and Nvidia grafic card and motheboad asus. LIbre no LAN internernet conecteted. help_?

  • when you first booted up & went through the wizard, did you see the connections?


    When you go to Libreelec configuration, what do you see under connections?

    NUC with LibreELEC Controlled by Logitech 350

    Beelink MiniMXIII S905 2G/16G 1000M Lan LibreELEC from NAND. CoreELEC 8.90.5 from usb

    MyGica 510b Now gone to the Great Media Centre in the Sky

    H96 Pro (S912) CoreELEC 8.90.5

    :)

  • So, what did you see when you first installed & the wizard automatically runs?


    Or if it was an upgrade, then go to the Libreelec configuration, (it will be under addons) & under connections tell us what you have?


    you should see LAN & possibly wireless connections, then edit & set DHCP to automatically get an ip address, then once that is working go back in & set the manual fixed ip address

    NUC with LibreELEC Controlled by Logitech 350

    Beelink MiniMXIII S905 2G/16G 1000M Lan LibreELEC from NAND. CoreELEC 8.90.5 from usb

    MyGica 510b Now gone to the Great Media Centre in the Sky

    H96 Pro (S912) CoreELEC 8.90.5

    :)

  • when you first boot libreelec it will have a small wizard, you set the host name it will ask if you want ssh enabled & show you any network connections you can then connect, if there is a network connection.

    Failing that, go to addons , my addons, all, Libreelec configuration, then run,


    On the left will be network, you should see wireless & wired networks, enable


    down, on the left connections highlight the wired connection, then edit


    ipv4 = ipaddress method. select DHCP


    that should get an ip address in the correct range, ie 192.168.x.xx


    once you have that, then I would reboot, go back in again & select a manual ip address

    NUC with LibreELEC Controlled by Logitech 350

    Beelink MiniMXIII S905 2G/16G 1000M Lan LibreELEC from NAND. CoreELEC 8.90.5 from usb

    MyGica 510b Now gone to the Great Media Centre in the Sky

    H96 Pro (S912) CoreELEC 8.90.5

    :)

  • This looks to me like a router issue. You're getting an IP address 169.254.168.158 whilst your subnet is 192.168.1

    LibreELEC Wiki pages

  • Did you do what I suggested? What did you see?

    NUC with LibreELEC Controlled by Logitech 350

    Beelink MiniMXIII S905 2G/16G 1000M Lan LibreELEC from NAND. CoreELEC 8.90.5 from usb

    MyGica 510b Now gone to the Great Media Centre in the Sky

    H96 Pro (S912) CoreELEC 8.90.5

    :)

  • Yes. New settings lan kodi static ip

    setting static ip address on kodi was accepted info system network kodi = no conected


    Test 1:

    ip KODI 192.168.1.88

    Geatway 192.168.1.1

    DNS 192.168.1.1

    MASK 255.255.255.0

    standard settings

    I also have the default settings on other computers

    No conected


    Test 2: (absurdly)

    ip KODI 192.168.1.88

    GEATWAY 188.175.112.129

    DNS 188.175.112.129

    Mask 255.255.255.0 or 255.255.255.192

    No conected


    Router is

    TP-LINK TL-WR841N (192.168.1.1/254 or DHCP 192.168.100/199)

    Switch is

    TP-LINK TL-SF1005D


    more information

    Test 3:

    Auto DHCP the router does not give the IP adress for KODI. Mac adress KODI is not visible in DHCP client list on router.

    Settings Static IP adress test 1,2 it is no connected

    Test 3 no conected.

    after every change ip address i do restart and control systém info settings network on kodi.


    maybe libreelec does not have a network card driver

    Edited 4 times, last by radekhodal ().

  • The 2nd test has a switch. Try a direct connection from the box/pc to the router.


    & or try different network cables.


    I have this


    under ipv4 I have ip address method: manual

    ipaddress 192.168.1.115

    subnet 255.255.255.0

    default gateway 192.168.1.254


    under DNS servers I have Nameserver #1 192.168.1.254


    I don't know much about routers, perhaps you could add the kodi box mac address manually

    NUC with LibreELEC Controlled by Logitech 350

    Beelink MiniMXIII S905 2G/16G 1000M Lan LibreELEC from NAND. CoreELEC 8.90.5 from usb

    MyGica 510b Now gone to the Great Media Centre in the Sky

    H96 Pro (S912) CoreELEC 8.90.5

    :)

  • This default ip

    169.254.144.237

    255.255.0.0

    And dns Google 8.8.8.8 , 8.8.4.4

    IT Is absurd.

    this setting is original, but it does not work.

    i mean switch tp link is a problem (169.254.144.237

    255.255.0.0)

  • disconnect the power switch and router. DHCP auto. I will try on Friday 10.8.2018

    I'm on holiday.

    I immediately write the result

  • hello guys ... problem is solved

    very very very thanks bubblegum57 and Iridium


    ....I had to turn off the pc

    ....pull the PC out of the 220v socket

    ....after a minute, plug in again 220v and power on pc


    static ip and auto dhcp works tested (all OK :-)))


    very very very thanks

    Thank you so much for your help