LibreELEC-RR 9.x [ Emulationstation | Retroarch | Pegasus | DolphinQT | Moonlight | Chrome | Spotify ]

  • Build RR-20190302-33d5f21 is online for Generic & RPi

    • Addon repo should be fixed
    • RPI video previews fixed -> no swapped color channels anymore
    • updated to latest LE9.1
    • upgraded Generic kernel to 4.19.26 / RPi to 4.19.25
    • updated to mesa-19.0.0-rc6
    • updated to nvidia 418.43
    • updated to xserver 1.20.4
    • updated Skyscraper to v3.0.5
    • updated Hatari to v2.21
    • updated several libretro-cores
    • updated citra & dolphin

    Did you upload this? Because whenever I looked in your google drive the past days there was your build from feb 22.


    Edit: Apparently I had to clear my cache

    Edited once, last by Kupo91 ().

  • Build RR-20190305-fed2e29 is online

    • Spotify installer should be fixed
    • updated Skyscraper to v3.1.0
    • added lr-bsnes-mercury-balanced to Generic build
    • updated Emulationstation to v2.8.2
    • updated VLC MMAL patch for RPi builds
    • updated several libretro-cores
    • updated citra & dolphin
  • Hi,


    awesome build. However compared to the rest dolphin is extremely loud and the volume bar in its settings is greyed out. Is there a solution for this?


    And is there a way to change kodi leia splash screen?


    Regards

  • dear friends,

    i got a Minix Z83-4U which doesn't seem to want to load with the current Build RR-20190305-fed2e29 neither with official 9.0.1.

    As far i understood, the problem is that it wants a 32bit EFI, which is present, however doesn't simply works...

    any idea how to get around this and load the latest build?

    i got after some trouble to load official 8.2.5 but again with the update method 9.0.1 doesn't work,

    perhaps something changed and messed things up?

  • It seems to work in one way or another Z83 mini PC

    milhouse   chewitt

    Any hints how to switch to grub2 to boot 32bit UEFI based systems?

  • Try alsamixer in a terminal to reduce the volume.


    About the Kodi splash screen you might be able to use this guide How to Change Kodi Splash Screen - Custom Startup Image - Home Media Portal and place a splash file in ~/.kodi/media


    Or disable it Bootscreen von Libreelec ändern - Raspberry Pi - Kodinerds.net - Deutschsprachiges Forum zum Kodi Entertainment Center

    EDIT:
    Something like pactl set-sink-volume alsa_output.temp_sink 75% works for PulseAudio. I guess I'll add some volume option to the RR Config later.

  • I maybe found the reason why rcb doesnt start dolphin..

    I compared the logparts of ppsspp and dolphin and here are the differences:


    PPSSPP:

    dolphin:


    Don't know what this means though. However I attached the files that are named in the error note. Maybe you want to check it..

  • This is most likely a RCB bug bug exporting game db to nfo's · Issue #202 · maloep/romcollectionbrowser · GitHub so you should report it there so it might get finally fixed at some day. /shrug

    Code
    1. UnicodeEncodeError: 'ascii' codec can't encode character u'\xa0' in position 21: ordinal not in range(128)
  • Thanks a lot! :) I did the same with my other issue (doesnt return to rcb after playing). Maybe you could take a look of it too and say what is missing in retroarch.start script. Log is probably longer than necessary because I didnt know where it ends.


    Thats how it looks like when launching /usr/bin/retroarch (returning to rcb works)


    https://paste.ubuntu.com/p/nxqbbqxhcq/


    And thats how it looks like when launching retroarch.start (doesnt return to rcb)


    https://paste.ubuntu.com/p/37w4p6zcvg/

  • If you use my retroarch.start script it can't return to RCB because my script stops Kodi before it launches any frontend.


    Again if you want to run anything else you have to export the audio drivers or else to Retroarch. As long as Kodi is running there is no guarantee that your emulator will gain access to your ALSA device for example.


    Btw. you probably have to use the "solo mode" mode anyway /shrug

    [RELEASE] Rom Collection Browser - Browse and launch emulator game ROMs

  • Didnt we fix this with



    (just with retroarch, not ppsspp) ?


    ..using the solo mode doesnt work. Then it doesnt even start the game

  • Did you enable KMS?

    The advanced.conf file says

    Code
    1. # Enable Kernel Mode Setting (KMS) for Retroarch which can reduce
    2. # your input lag and overall gaming experience for certain lr-cores
    3. # valid options: false / true
    4. RR_KMS=false
  • The advanced.conf file says

    Code
    1. # Enable Kernel Mode Setting (KMS) for Retroarch which can reduce
    2. # your input lag and overall gaming experience for certain lr-cores
    3. # valid options: false / true
    4. RR_KMS=false

    Btw. you should read the last changelogs...

    Well you could try to delete this completely:

    Code
    1. # Freeze Kodi / stop audio
    2. kodifreeze.sh freeze muteonly
    3. # Switch back to Kodi & start audio
    4. kodifreeze.sh unfreeze muteonly
  • Well you could try to delete this completely:

    Code
    1. # Freeze Kodi / stop audio
    2. kodifreeze.sh freeze muteonly
    3. # Switch back to Kodi & start audio
    4. kodifreeze.sh unfreeze muteonly

    This works :D

    However I just tried it with ppsspp and retroarch. In pcsx2 I have kodifreeze in this if condition. How do I have to manage this?



    Btw. you should read the last changelogs...

    You probably mean this:


    I've added a first hacky implementation of a config addon. Check out Addons -> My add-ons -> Services -> RR Configuration to configure the emulation stuff. This will replace the advanced.conf file!


    Shall I delete this file?

  • Kupo91  
    Yes you can delete the file & rr-config dir.

    This could work:

  • Kupo91  
    Yes you can delete the file & rr-config dir.

    This could work:


    Perfect thanks a lot :)

  • Alucard I just wondered if you also get this notification if you start a PS2 game via emulationstation or any other frontend?


    "CDVD plugin failed to open. Your computer may have insufficient resources, or incompatible hardware/drivers. Press OK to go to the Plugin Configuration Panel."


    If not, which plugings did you select in pcsx2 settings? Since you have the same NUC as me this should also work for me then