Can't Compile LE 8.2

  • Hello everyone long time user of LE thanks to the departed Kszaq


    I have been trying to compile LE 8.2 myself using Ubuntu 18.04 and not matter what i do i get the same error over and over
    .
    I have tried LE 8.2.1.3 from Kszaq's github and i have also tried from the 8.2.5 LE source for the RPI 2

    Not sure what i am doing wrong but this is the error i get everytime

    collect2: error: ld returned 1 exit status

    Makefile:655: recipe for target 'make' failed

    make[3]: * [make] Error 1

    make[3]: Leaving directory '/home/****/LibreELEC.tv.8.2.5/build.LibreELEC-S805.arm-8.2.5/make-4.2.1/.x86_64-linux-gnu'

    Makefile:798: recipe for target 'all-recursive' failed

    make[2]: * [all-recursive] Error 1

    make[2]: Leaving directory '/home/****/LibreELEC.tv.8.2.5/build.LibreELEC-S805.arm-8.2.5/make-4.2.1/.x86_64-linux-gnu'

    Makefile:534: recipe for target 'all' failed

    make[1]: * [all] Error 2

    make[1]: Leaving directory '/home/****/LibreELEC.tv.8.2.5/build.LibreELEC-S805.arm-8.2.5/make-4.2.1/.x86_64-linux-gnu'

    Makefile:12: recipe for target 'image' failed

    make: * [image] Error 2

    Any help with this would be amazing Thanks

  • this isn't working (without some ugly workarounds)

    try Ubuntu 16.04 or use workaround from here [FIXED] Compilation under Ubuntu 18.04 LTS


    Thank you for the response.... I tried the workaround and it still seemed messy so i downgraded to 16.04

    done some tweaks and thought i had it all sorted then got this issue

    Any idea how i can solve this one ?


    Edited once, last by CvH: paste log into code container ().

  • These are the 2 i'm using
    GitHub - kszaq/LibreELEC.tv at 8.2.3.1 = S805


    And


    GitHub - LibreELEC/LibreELEC.tv: Just enough OS for KODI -b libreelec-8.2 LibreELEC.tv.8.2.5


    What i am trying to do is update LibreElec 8.2.3.1 HD18Q S805 to 8.2.5, I have very little knowledge of this kind of stuff but i am very willing to learn as i know many people still use the Amlogic S805 devices, Even if it just pro-longs the life for a little while longer at least i will know i have done something to help the community.


    If i'm able to get all the details and teaching or so forth i will continue and try to bring LE 9 to the S805 devices.... I have 2 of these boxes so testing isn't a problem.. I've tried google and searching for things as much as possible but there seems to be very limited information on how to do this.


    Thank You for your help so far :)

  • pls try to bump libcec to 8adc786 and remove the patches if there is any at that dir (not the cec-framework folder) and run again

  • Ok that's cool, I will have a mess around a little later anyway while waiting on your opinion/suggestion :)

  • Well i tried the change you suggested and it still got an error at the same place


    Just tried again on 14.04 without changing anything from Kszaq's 8 2 3 1 build and yet again it failed......................

    God knows why but i've spent so much time on this and not getting anywhere.


    So i think i will stop here and just face that the AmLogic MXQ S805 has reached as far as it will go.

    Shame really as it is a great little box with LibreELEC running on it


    Thank you for all your help

  • OK..... I tried again as i do not like being defeated and i ran into this error, I believe it was the same error as my last attempt



    Any ideas what could be causing this........


    EDIT.......

    A little digging shows this is to do with Time Zones............

    Edited once, last by Chewy ().

  • Only time i used sudo was for these commands


    Some of them may not be needed for LE 8.2 but the end goal will be 8.2.5 and then continue to 9.0


    They are the only commands i use sudo for and from my understanding you have to use sudo for these commands

  • Try cleaning tz package and build it again

    Code
    1. PROJECT=S805 arch=arm ./scripts/clean tz
    2. PROJECT=S805 arch=arm ./scripts/build tz

    I think I had the same error few times in the past.


    Btw: Release 8.2.3.1 · kszaq/LibreELEC.tv · GitHub builds without a problem on my Ubuntu 16.04.4 LTS.

    Blu-ray Disc Java menus support - forum thread, Github

    my lamp addon (unofficial/community) (limited no support)
    my touchscreen support and instructions by Grruhn (now touchscreen addon exists in repository)

  • Try cleaning tz package and build it again

    Code
    1. PROJECT=S805 arch=arm ./scripts/clean tz
    2. PROJECT=S805 arch=arm ./scripts/build tz

    I think I had the same error few times in the past.


    Btw: Release 8.2.3.1 · kszaq/LibreELEC.tv · GitHub builds without a problem on my Ubuntu 16.04.4 LTS.

    I had the same issue with kszaq's build..........


    I tried what you suggested and ran into that same error after running

    Code
    1. PROJECT=S805 arch=arm ./scripts/build tz
  • It might be nothing but a little above there’s


    ‘fatal: no names found‘


    which has todo with git describe and the git repository


    Try doing a ‘git fetch --all‘ to get a copy of the remote tags and make sure you’re not deleting the .git folder as it won’t build without it as that’s where it auto picks up the commit hash