Geniatech Mygica HDStar DVB-S2 USB HD not working

  • Hi, i've problem with dvb960, tuner is recognized but don't tunes any thing. I solve this in my case, suppliying voltaje to lnb with another satbox, because in my case and I think is a driver problem, the dvb960 does not send the 12v to lnb....

    May be this can help you... Have you tested output voltaje from your tunner vía multimeter?

  • Hi sdf, anything new?

    Thanks.

    Sadly no.

    I've sent a message to Crazycat as suggested by CvH but got no answer.

    What about trying to make a diff between updatelee and crazycat sources (and maybe original kernel and media_build sources)?

    I'm not a programmer nor a great expert, but maybe starting from ds3000 and m88ds3103 sources we will find the culprit.

    What do you think?

    To Danilp.

    Thank you, will try your suggestion.

    Anyway I think this should be solved by making the necessary changes to the drivers, because updatelee drivers work perfectly.

    Bye,

    sdf

    Edited once, last by sdf ().

  • Hi Aiden.

    I've diff between Updatelee sources and 5.3.1 kernel sources, and found differences in ds3000.c, m88ds3103.c and in particular many differences in dw2102.c.

    Tried only to substitute the .c and .h files but had a compile error.

    Did you find diffs only in ds3000.c with Crazycat drivers?

    Did you examine also dw2102.c?

    Anyway, even if you manage to compile patched Crazycat drivers, how could this be integrated into Libreelec?

    Updatelee drivers work out of the box.

    Could it be possible to add them to the list of addon drivers in Libreelec?

    Bye,

    sdf

  • Anyone has found a solution for ds3000/m88ds3103 devices?

    Still can't use libreelec.

    Only updatelee drivers.

    Is it possible to report the bug to kernel developers?

    Sent a message to Crazycat but he didn't answer.

    Bye,

    sdf

  • Would like to know if all the others with hdstar have the same problems

    sdf

    I've got the same problems spf. I had it working in LibreELEC 8 with Crazy Cat but without being able to view most HD channels and was able to live with that. This weekend I foolishly updated to LibreELEC 9 without thinking and now my HD Star v3 is not working.


    Was hoping to pop on here to see some positive developments on the issues but it appears to be getting worse. Will have to revert back to 8 or maybe try an install on raspbian.


    I purchased the device as it was supposed to be compatible. Sods law they release a non compatable variant just as I was in the process of buying ;(

  • Sadly there are no news.

    On bugzilla kernel nobody answered.

    Don't know how to change crazycat drivers.

    Last chance are updatelee drivers.

    Don't know how to contact someone to include them in Libreelec

    I still can't use Libreelec.

    Using Ubuntu.

    Bye,

    sdf

  • Hi,


    Just to report back on my most recent experience of testing the HD Star v3 device's compatibility with LibreELEC:


    LibreELEC 9.2 + default drivers: No device in TVheadend (see here for log)
    LibreELEC 9.2 + 'DVB drivers for TBS': Partially working, but lots of transponders don't work (see here for log)

    LibreELEC 9.2 + 'DVB drivers for DigitalDevices': No device in TVheadend (see here for log)

    LibreELEC 9.2 + 'DVB drivers from the latest kernel': No device in TVheadend (see here for log)


    At the moment I've found the most reliable option is using the Montage-3103b.v2 branch from b-rad-NDi's media_tree repository, which is based on Linux version 5.2-rc4. Brad appears to have done a lot of work cleaning up the code required for support of the 3103b device. So far the work seems to have been restricted to supporting the 3103b demodulator itself and any associated Hauppauge devices, hence I needed to write a small patch for the dw2102 driver, to get it to use Brad's updated code when the HD Star v3 USB device is detected. I've posted the patch, and some additional information on the GitHub page for Brad's media_tree branch (see here). I've no idea if the patch meets any particular set of guidelines or standards published for the Linux kernel, and, as far as I am aware, it hasn't been tested by anyone else, but it is currently the most reliable way for me to use the satellite tuner, being more reliable than any of the LibreELEC drivers, or any approach I may have previously described in this thread.

  • I have really no complaints with my HD Star v3 and updatelee drivers (see Chris Lee / v4l-updatelee · GitLab). Compiled latest version with kernel 5.4.2 and it's all working reliably.

    The real problem is that there are no drivers for it in LibreElec and really don't know how this can be done.

    The only thing I'm sure is that actual Libreelec drivers don't work at all and updatelee work instead.

    Bye,

    sdf

  • Compiled media build in ubuntu 19.10 (kernel 5.3.0).

    Seems working well.

    Tuned several stations in Hotbird and no error.

    Anyway will try more deeply.

    Tried also latest Milhouse build, but it seems to me that Crazycat drivers aren't included.

    Can some compile a build with latest Crazycat drivers?

    Thank you,

    sdf

  • Sorry crazycat,

    do you mean Ubuntu or Libreelec logs?

    btw, tried to compile media_build against latest 5.5 kernel, but it throws this error:

    Everything goes well with 5.3.x and 5.4.x kernels

    Bye,

    sdf