Can't boot libreelec on Intel G4600

  • hello there,


    I upgraded my old amd a6 6400k to the Intel g4600. The old one refused to play my 4k footage so I decided to upgrade fully including a b250 gigabyte and 8gb ddr4.


    I was expecting libreelec to boot but after the freedos (?) message the system just powers off and after a few seconds powers on again.


    Regardless to say, I cannot boot fully into kodi or libreelec. Is there something I missed? I tried the special gen 8 build for intel in this forum, even grabbed the le9 nightly. All with no result. Not even the installation usb would boot.


    I do have some debug, but it's small since it's crashing this early.



    Hope someone can be of help, since I'm out of ideas.


    Thanks

  • Line 102:

    19:07:40.159 T:139968212531328 NOTICE: Host CPU: Intel(R) Core(TM) i3-2310M CPU @ 2.10GHz, 4 cores available


    Well that's not really a G4600?


    Anyway make a fresh installation and post a dmesg output afterwards as mentioned above.

  • Bios and box really say G4600. Guess libreelec or kodi doesn't recognize the CPU properly.


    Logs are difficult, since it already crashes just after the syslinux message.


    Just grabbed the patched up version and trying again, plain 8.2.5 I got zero logs.

  • I got zero logs.

    I doubt that... But try again with the latest Milhouse Generic build, not one from the end of February. LE 8 is almost EOL.

  • Titbb


    Kaby Lake is supported since Linux kernel 4.5 so I hardly doubt LE8 does not recognize it or is wrong. Also your build (devel-20180228210338-#0228-g1eb0ca9) is pretty old.


    Get a recentLE9 build:


    LibreELEC Testbuilds for x86_64 (Kodi 18.0)

    libreelec-generic.x86_64-9.0-milhouse-20180515210351-#0515-gc0da3f5.tar


    Or try a recent LE8 build:


    libreelec-generic.x86_64-8.2.5.img.gz


    I doubt that... But try again with the latest Milhouse Generic build, not one from the end of February. LE 8 is almost EOL.

    Correct me if I'm wrong but there isn't even a beta or RC release of Kodi 18 so IMHO most users will stick to LE8.2.x for a while.

  • I doubt that... But try again with the latest Milhouse Generic build, not one from the end of February. LE 8 is almost EOL.

    I just tried, clean 8.2.5 install, then updated to the 15 may generic milhoue build, and still it just shuts down on me.


    Debug logging is enabled, but the only logs i get to see is when i boot it on my old working system. Any idea how to force write the logs before it powers down? I do however have a 01_KODI_OTHER.log, is that any good?

  • Do a hard reset via the LibreELEC Settings addon for a truely clean start.


    Strange, the i3 2310M is a 7-year old Sandy Bridge CPU. The G4600 is a 1-year old Kaby Lake CPU.

    You would think that Linux knows the difference between the two.

    Perhaps you have bought a gray-import CPU which has been 'refitted' with an old CPU...?

  • Do a hard reset via the LibreELEC Settings addon for a truely clean start.


    Strange, the i3 2310M is a 7-year old Sandy Bridge CPU. The G4600 is a 1-year old Kaby Lake CPU.

    You would think that Linux knows the difference between the two.

    Perhaps you have bought a gray-import CPU which has been 'refitted' with an old CPU...?

    The i3 2310M is a mobile/notebook cpu that was mostly soldered on the board. If he uses a B250 board this wouldn't fit or run on this socket.


    Titbb

    Can you tell us your full specs of the system? So who manufactured the board i.e.?

  • I disassembled everything (board was from a friend) and I noticed that a few of the CPU pins were bent. I'd reckon this caused the shutdowns.


    Still strange it misidentified the CPU itself.

    Tomorrow new morherboard incoming so hoping problems will be solved. Damn intel for those very fragile pins!


    Sorry for (probably) wasting your time and thanks for the helps