[S812] Support

  • I thought I would kick off this thread with some positive news. I want to thank drieschel for the work on the S802 builds!!


    I can confirm that this is running on an M8S+ which I upgraded from a working OE 6.95.1.1 kerber build


    LE is much better! I have never been able to watch live TV video from a usb tuner with OE and with this LE build running TVheadend - I now have the most affordable pvr in the world.


    I will note that it took a few restarts to get running. The IR remote is not working (I have an RF MX3 so no worries there) and I sometimes don't get a clean boot. It could be due to my box having to have pins shorted while working with different firmware, but when it does boot it is running well.


    Since the IR does work from the kerber build, drieschel you could look into his source for any differences: GitHub - surkovalex/OpenELEC.tv at openelec-6.0


    One other note - not specific to this build - the tvheadend 4.2 addon is still missing the ATSC predefined muxes. This was being looked into in the past but I haven't seen any updates on it. The versions at index - powered by h5ai v0.29.0 (https://larsjung.de/h5ai/) have this issues as well (tested on Rpi3)


    Thanks again for the great work on this release. I'll continue testing and encourage others with working OE builds to jump in on the upgrade to LE!!

  • A couple of testing updates...


    I still seem to have about a 50% boot success rate. Again - not sure if this is due to issues with my box or something in the code between S802 and S812. Will be interested to hear others results. When it's running it's quick and solid.


    I seem to have an issue with writing to an SD card. The card mounts and if I ssh in it seems that it has read/write/execute permissions for all...but I can't seem to write to the drive. I tried creating a folder through LE file manager and I tried using the card as recording space for tvheadend. Both seemed to reveal a read only status with both NTFS and extfs formats. Since I am able to mount and record to an external usb drive, it seems this would be some sort of sdcard limitation.


    This is the difference between the way the two drives mount ("REC" is the sdcard and "drive" is an external usb hard drive)

    Code
    drwx------    3 1000     1000          4096 Aug  8 21:46 REC
    drwxr-xr-x    4 root     root          4096 May 14 10:55 drive


    Maybe this is normal for LE - but I want to be able to record to sdcards, so I will need to solve it.


    In the meantime, I'll keep running tests on this system and post any other issues...but so far the M8S+ is happy with LE!!

  • Hi edit4ever,


    glad to hear that the build is even running on a S812 device. But it's probably not very healthy for it, because it uses a "wrong" device tree. Could you please give this thread a more convinient name? [S812]support for example. Because it's about S812 devices and not about S802 devices. :) Anyway, there will be unoffical support for S812 devices soon.


    Regarding to your question about the IR: You can try this remote.conf. You only have to copy it in the config folder on your device. This should work.

    _________________________________
    Have you tried turning it off and on again?

  • Thanks! That remote.conf worked.


    I think a moderator will need to change the thread title - I don't seem to have access to it.


    It may not be a "healthy" device tree...but it seems to work really well. Live TV, online streaming, local file playback all run smoothly. It gives new life to older boxes!

  • Here's another user of M8S+ (S812) who would like to see Libreelec support for this device...


    Edit4ever, power off on M8S+ works fine or just reboot device?

  • You can power off but can't power back on by the remote. You have to pull the plug. The remote only worked in kodi after installing a remote.conf file.


    The blue and red lights work correctly with power on and off.


    I still have a hit and miss boot. Sometimes it just hangs and I have to cycle the power...but when it boots it seems to run well.


    For me it was worth it for the ability to use live tv with an attached usb tuner. I was unable to get video to play smoothly using OE.

  • Power on & off malfunction is a blocking point for me!
    I'll wait for a stable release as OE 6.95.1.1.

  • It's likely an issue with the remote.conf file I used.


    I will do some testing tomorrow and see if I can resolve.


    I'll also take a look at the logs and see if I can see what may be causing the boot hang issue.


    Also looking forward to testing an LE 8 - alpha or beta if it comes along. ;)
    There are some nice pvr improvments - which is my main use.