how to enable "wait for network" by default in service.libreelec.settings

  • I am trying to make "wait for network" enabled by default in service.libreelec.settings add-on. I assume you need to edit this in the connman.py file but I can't seem to figure out to have it enabled once Libreelec is installed. Any help would be great. Thanks

    Edited once, last by hscotty55 ().

  • Make sure you create a diff patch and store it somewhere like packages/mediacentre/LibreELEC-Settings/patches/LibreELEC-Settings-01-new.patch. If you just edit the unpacked sources in the build.LibreELEC* folder between build (re)runs the change is not applied.

  • I tried everything but the patch because I did an update from a .tar file usingLibreELEC-Odroid_C2.aarch64-8.2.5.tar and tried a hard erase as well within Libreelec. And I don't understand the patch method. The wait for network is greyed out but the 10 sec below it is now visible by default. If I click the wait for network button the wait 10 secs goes away. I edited build LibreELEC-Odroid_C2.aarch64-8.2.5 and unsquashsf the SYSTEM file and made my changes to connman.py and repacked it and that was my result. I am a beginner at this so feel free to talk to me like I am a 3 year old so I understand if I am doing something wrong.

    Edited 2 times, last by hscotty55 ().

  • As an alternative, is there anywhere I can put the network_wait file with the code:

    WAIT_NETWORK="true"
    WAIT_NETWORK_TIME="10"

    inside the SYSTEM file to make it install automatically. I know once you enable wait for network it creates the network_wait file inside the storage/.cache/libreelec folder. I know when I ssh into the system and drop the network_wait file into storage/.cache/Libreelec it enabled wait for network in Libreelec Configuration. I tried it in the usr/lib/libreelec folder but it didn't work.