Test LibreELEC images with KODI-19 for S9xxx

  • The X96 device tree describes the x96max remote, hence it works OOB. If you can point me at a working remote keymap for the Y5 we can create a device-tree that does that same thing.

  • hi chewitt


    Is there news of the final move to kernel mainline for wetek play2 ?


    Is there progress in support video 4k 60 ?


    Why is the delay so far?

  • G12A support (which is the target of commercially funded work) needs to reach the same level of incomplete as GX and then video work (which is largely common to both) can continue. There is already 4k 8-bit support, but as most 4K video uses 10-bit formats that's not so useful. Intel's HDR plumbing is also starting to fall into place so we've started to look at what Kodi needs to use it. There is also refactoring/rework of the ffmpeg stateful code as we learned lots from writing stateless support for Allwinner/Rockchip. It's all green-field coding so it's often a "two steps forwards, one step backwards" process. The nice thing is that we've successfully positioned Kodi (and LE) as the go-to demo application for a number of development efforts which is attracting some nice contribution from the wider Linux community - although a lot of the activity isn't public visible. GXBB devices like the WP2 have a few quirks that need to be ironed out (currently a bug in audio support) but we'll circle back on that generation shortly.

  • Just made switch up from LLibreELEC-S912.aarch64-9.1-devel-20190411090352-68723cf.img.gz to LibreELEC-AMLGX.arm-9.1-devel-20190417142806-68723cf.img.gz On basis Chewitt mentioned that Liberelec support going forward, would be based on arm HERE

    (Note erased SD and installed latest using LibreELEC USB-SD Creator)


    Understood that unlike earlier builds, required to edit uEnv.ini on SD to ensure pointing to correct dtb for my KVIM2 Pro. (Which I have done)


    edited uEnv.ini

    Code
    1. dtb_name=/dtb/meson-gxm-khadas-vim2.dtb
    2. bootargs=boot=LABEL=LIBREELEC disk=LABEL=STORAGE quiet console=ttyAML0,115200n8 console=tty0

    KVIM2 refuses to boot into Libreelec after final preparation of SD, remaining stuck on khadas boot image?


    Hmm what have i missed?


    ---edit--- Also installed LibreELEC-AMLGX.aarch64-9.1-devel-20190417142453-68723cf.img.gz onto SD then edited uEnv.ini to point to "meson-gxm-khadas-vim2.dtb" with same unable to boot into Libreelec outcome. (apologies for poor photo)


    RPi4, 16Gb SD, (Raspbian Buster & LibreELEC 9.2) Onkyo TX-SR608 AV Receiver, Philips 55PUS7304 4K TV

    KVIM2 Pro, eMMC 32GB (Android 7) 8Gb SD (Varied OS) LG 27UD69-W 4K Monitor, AudioEngine A2+ Speakers

    Edited 3 times, last by MikeKL ().

  • Hello @all,


    i'm a newbie at this forum and also no profi with xbmc, kodi, LE etc. Ich use a X96 with S905X and new a X96 Max with S905X2 mediaplayer. I tried the last version of LE (LibreELEC-AMLG12.aarch64-9.1-devel-20190417171703-68723cf.img.gz) for the S905X2 mp. Very good job, thanks! :thumbup:


    I have connected over HDMI, but i have no audio, what am I doing wrong?


    greetings

    CT

    X96 max S905X2 (4/32), X96 S905X (2/16) :)

  • I found here in the forum the night constructions, working perfectly.

    I also found here the semi-official images running perfectly.

    I'll see what I can do to help balbes150 with debug log run UART. :thumbup::thumbup:

    Maybe I need to open a topic here in the forum I'm going to do this over the weekend with free time.

    Thank you balbes150 and kszaq for not being disappointed.^^

    And make the joy of thousands of people.:)

  • The audio drivers for G12 hardware are not fully upstreamed yet, and since it's Easter week and lots of people downed tools for a while that's not likely to change for a bit. As has been clearly written (but not read) in previous posts, only USB audio devices will work on G12 things right now.

  • balbes150 Ref previous post and issue unable to get 20190417 arm & aarch64 builds, to boot up correctly on my vim2 Pro.


    Just installed LibreELEC-AMLGX.arm-9.1-devel-20190419173639-68723cf.img.gz onto clean SD, then modified uEnv.ini with text editor to point to meson-gxm-khadas-vim2.dtb before completing build SD and then booting up for first time via vim2


    Unable to complete boot into LibreELEC


    Freezes at LibreELEC Splash image with "LibreELEC (community): devel-20190419173639-68723cf" in top left corner of screen.

    RPi4, 16Gb SD, (Raspbian Buster & LibreELEC 9.2) Onkyo TX-SR608 AV Receiver, Philips 55PUS7304 4K TV

    KVIM2 Pro, eMMC 32GB (Android 7) 8Gb SD (Varied OS) LG 27UD69-W 4K Monitor, AudioEngine A2+ Speakers

  • I'm excited to see if the Audio on hdmi Works at odroid N2.



    How can I help with the Remote Control of the y5? Keymap Editor.

  • X96 Max

    2GB/16GB


    I tried the two releases


    LibreELEC-AMLG12.aarch64-9.1-devel-20190417171703-68723cf.img.gz


    LibreELEC-AMLG12.arm-9.1-devel-20190417175023-68723cf.img.gz


    burned using LibreElec USB-SD Creator on Linux.


    Both boot without problems, and the remote works well, but neither enable the wired network.


    I see a few previous posts saying that wired is working (although wifi not) so wonder what I might have done wrong to cause this.


    Suggestions welcome, thanks.


    EDIT: I should have mentioned that the wired connection works fine when using Android.

    Edited once, last by JohnBoyz: Added info ().

  • Wired is working, flash with etcher again.

    Tried again, this time using Etcher, but have the same result.


    Strange.


    The sha256sum of both .gz files checked out.


    Unless I have a different hardware NIC in this box ......