Bluray Playback ends in a crash after a few minutes

  • Hello Community,


    i have a problem with disc bluray playback on my system. I´m on kodi 17.6, it´s running on an intel Kaby Lake G3930 with integrated graphics. For bluray playback i use a Panasonic UJ-265 device. My problem is when i start playing a disc it plays a few minutes and than kodi is crashing. When i restart the disc the same problem on the same place in the movie.

    When is restart my computer with the disc inside the device and start playing again, the movie is playing without any problems. It´s only when i start the computer without a disc and insert the disc first when the computer is booted.


    Here is a debug log.


    Edit:

    It seems the error comes from the udfread.c file and the function ssize_t udfread_file_read(UDFFILE *p, void *buf, size_t bytes). It is used by libbluray.


    It returns a -1. As we can see in the debug log.

    Edited once, last by blob810 ().

  • The first thing to do is test a current Milhouse Leia build because nothing is going to be fixed in Krypton now. If the issue still exists in Leia then it needs to be reported to Kodi devs via their forums.

  • Ok, I tried the latest Milhouse build from today. No error anymore. The disc is playing without the error as I described above. But to stay on the alpha builds at the moment is my last choice. In the latest build the display rate is not adjusting when playing 24p files. My tv stays on 50Hz.


    Is there a way to update the libbluray binary on krypton to 1.0.1 without compiling the whole package? Where is the location from the binary on the storage. I´ll try to swap the binary to 1.0.1

  • You'll need to build the entire distro image as the binaries are in a read-only filesystem. I'm not au-fait with the patches in Milhouse's release but if it has the current work on whitelisting which replaces "adjust refresh" you'll need to whitelist the modes it will switch to, so check that.

  • Thank you chewitt , that was it. I set my resolutions with frame rates in the witzelist. Now the frameswitching works. Now I have problems with crashed black menus. Because I cannot change the RGB settings of my TV to full, and the settings in kodi "limited color space" are useless.


    Anyway, this night I compiled LE8.2.4 with escalades Libbluray version 1.0.2 and installed it. It ends with the same error when playing a BR disc. So I think the error is not the Libbluray version.