Spotify Connect Web


  • In both situations I have HDMI audio to Yamaha AV receiver.
    If you have a spare pi you might try volumio with pre-built chroot?Is the soundquality difference not an ALSA issue?


    I will experiment with the pre-built chroot on LibreELEC, but for the moment it does not install.


    The sound quality likely lies with ALSA.


    However, bear in mind that:
    - Volumio is designed for sound, whereas
    - LibreELEC is designed for Kodi, which uses an audio sink of its own (not ALSA).
    ALSA configuration is therefore likely more refined on Volumio than on LibreELEC


    I will nevertheless do my best to improve the sound quality of the addon.


    I welcome help, in any form, in this endeavour

    @

  • The state of play:


    The addon uses a slightly modified packaged release of spotify-connect-web, from which libasound.so.2 is removed.
    I tried to use libasound.so.2 of the packaged release, in vain.
    The addon therefore uses libasound.so.2 shipped with LibreELEC, which works.


    I also tried to install the pre-built chroot of spotify-connect-web.
    But this fails because of invalid tar magic.


    Both the libasound.so.2 route or the pre-built chroot route might yield better sound quality.
    But I am at my wits' end.


    If anyone here knows how to improve sound quality, please report here, or update the addon.


    Thank you in advance.

    @

    Edited once, last by awiouy ().

  • Hmmmm...i changed some settings of my kodi audio output device pi-hdmi 7.1...set output configuration to best match and unchecked the normalize levels on downmix....much better sound...close to volumio


  • Hmmmm...i changed some settings of my kodi audio output device pi-hdmi 7.1...set output configuration to best match and unchecked the normalize levels on downmix....much better sound...close to volumio


    Great!
    By the way, alsamixer now ships with the multimedia-tools addon.

    @


  • For information, pre-built root is outdated for now.

    @

  • Hi,
    thanks for this plugin and your work! Unfortunately I'm having a small problem. Not even sure if you can help.


    I'm using latest stable LE on RPi2 and attached to that I have a USB Sound Card. Wich works fine with Kodi.
    When I use the Wizard of Spotify Connect and select the 5.1 device. I receive this message in my log:


    The List of devices:


    If I select alsa, I can hear sound via HDMI on my TV.


    Any suggestions what to do next? As I assume it's not 100% plugin related but alsa related?


  • Wow that was fast.


    spotify didn't crash but I can't hear anything. Everything seams to work fine except there is no sound ;)


    LOG:



    More log:


    I was switching the output devices. the first block of log lines is from selecting the 5.1 device from that list:



    tried every device, sound is just working when I select ALSA and it uses HDMI.


    Best
    sesc

  • According to me the problem lies here:

    Code
    1. Sep 08 22:28:04 openelecpi sh[12021]: Unable to acquire device:  Device or resource busy [surround21:CARD=Aureon51MkII,DEV=0]


    I gather that Kodi and Spotify Connect Web can not share the device.


    To verify that this is the case:
    - set Kodi to use another device, eg PI:HDMI,
    - set Spotify Connect Web to use the device, and
    - restart Spotify Connect Web (eg by re-running the wizard and then confirming the settings with OK)


    If Spotify Connect Web plays, you will unfortunately have to decide which of Kodi or Spotify Connect Web will use the device.


    A similar problem was discussed here, and solved with DMIX.


    I will assess if DMIX may be applied to LibreELEC, but it looks daunting and device specific.
    Do therefore not expect this to happen soon.


    I will nevertheless submit the current fix if you confirm it enables Spotify Connect Web to use your audio device.

    @

    Edited once, last by awiouy ().


  • You answered just too fast ;). I was updating my latest post: I do have sound now! Waiting for 30minutes. Watching an episode. And bam. SOund. But it's sped up. Everything is twice as fast as it should be. I'll try some more settings. rebooting etc. and get back too you afterwards. But the new version is working! fixed my initial problem.
    The early version (without the config wizard) was working too, but also too fast in playback.



    Best
    sesc


    **UPDATE**
    After the reboot I get this:


    endless loop.


    alsaaudio.ALSAAudioError: No such file or directory [default]

    Edited once, last by sesc ().

  • The log you provide does not enable me to assess.
    My first impression is that the device is not ready when the service starts.

    @

  • So I just tried a fresh install. And another reboot. deleted all config files and folders. Same result. Even the Config Wizard failed. I can see the list, but after choosing an Item an error appears and refers to the log. But nothing in journalctl. The ADDON_HOME$ Variable is set the /storage/.kodi/userdata/addon_data/service.spotify-connect-web so I had to copy the file their. The Version earlier had a differnet ADDON_HOME I think, it was just addon_data. However. I entered the audio device manually after setting HDMI as Audio Output for Kodi to avoid any problems.
    I ended up Installing with OpenELEC · Issue #82 · Fornoth/spotify-connect-web · GitHub here. Log file still shows only the following:


    The Line with the path was my attempt to find out the destination of ADDON_HOME$


    Any other ideas? I don't even see the old alsa device (what was my TV as I posted yesterday) any idea what happened?


    Best


    Sesc

  • Hi sesc!


    Sorry to read you are struggling with the addon.


    First, the addon home folder is /storage/.kodi/userdata/addon_data/service.spotify-connect-web (also smb://libreelec.tv/userdata/addon_data/service.spotify-connect-web).
    There is no need to reinstall LibreELEC or the addon, deleting settings.xml in the addon home folder is enough to reset the addon.


    Then, the service will only activate onboard audio if no other sound device is active or if the service is configured to use onboard audio.
    It sounds complicated, but the intention is to avoid activating onboard audio, because it might interfere with operation of other/unknown audio devices.


    In summary, the service (probably) does not start onboard audio because your USB device is active when the service starts


    To enable onboard audio:

    • dtparam audio=on at the console or in config.txt
    • restart the wizard to use onboard


    Hope this will help you use onboard audio.
    We will assess your USB device when this is done.


    Keep cool

    @

    Edited once, last by awiouy ().


  • I see! Makes sense! Thanks for that workaround! I know that these USB soundcards are a pain in the ass. Took the LE (back then OE) devs a long time till everything was working. Thanks a lot for your work and help! Much appreciated!


    For now I can listen to music via TV while I'm working ;) better than my crappy laptop speaker. Thats all I need right now ;) Thanks a lot!


    Best


    sesc

  • Hello sesc,


    Thank you for the feedback. I am glad your are able to use the addon.


    Do not forget you can plug the jack of your Pi to an audio system, and route Spotify playback via the jack ;)


    Cheers

    @