rpi3 b+ usb LAN adapter issue (to win10 samba)

  • Dear community

    I have a weird issue with the new rpi3 b+ and samba. It keeps disconnecting and explorer freezez on win10

    I can see folders but a few moments later it disconnects. (tried to copy, and stream videos from connected external hdd... it worked before with openelec)

    Libreelec version is the newest 8.2.4

    I make min smb to 1, max 3, tried minmax to 3. Tried a different openelec smb.conf, a libreelec smb.conf file from another topic, but cant fix by myselft.

    pls help with a step by step easy description if you know how to fix it!


  • same board, same libreelec version, the same problem... No matter how many data you transfer but after 15-20 minutes it drops off (for ecample: after 15-20 minutes of watching movie remotely vlc stucks and throws "BAD file descriptor" errors) and after 1 minute it is back again. Forcing other SMB versions does not help. Plus I can not use wireless at my home because I have too many wifi active connections around me causing instability and poor bandwidth.
    Former RPi3 B was ok with that but on Rpi3 B+ is the same configuration faulty.
    I am kind of desperate..

  • So, is there any known planned fix or we have to report bug?
    And yes... I expect "blocked until raspbian ethernet drivers are woring" or something like that....

  • Try 8.2.5 which includes LAN driver and firmware fixes for 3B+.

    There are still remaining 3B+ LAN driver and stability issues which the RPi developers are aware of and actively working to fix. Hopefully these issues affect only a minority of users (those with unusual network VLAN/duplex/cable configurations, or 3B+ boards with slightly marginal RAM chips that may require a voltage bump) and will be fixed sooner than later in software when we will release an LibreELEC 8.2.6 update.

  • I seem to have the same LAN performance from 8.2.4 -> 8.2.5. I have two 3B+ units with different modes of connection - 1) Direct LAN via switch 2) LAN via wireless bridge. Both units show odd SAMBA performance as they did with 8.2.4. WinSCP doesn't seem to have the same same dips/crashes in throughput (See attached).

    I believe I would not fall into an unusual network configuration for at least one of my units. I've attempted a memory over volt (over_voltage_sdram=1) with no change in performance.

  • TDown I don't know what the graphs represent, are you reading from or writing to the 3B+? If you are writing to the 3B+ then where is the data being written - if SD card, could that be the bottleneck?

    I have the following:

    RPi3+, SanDisk Extreme Plus (32GB), wired Gigabit ethernet, running latest Milhouse LibreELEC 9.0 build (Samba 4.8.0)

    Windows 7 PC with SSD, Gigabit Ethernet

    Both clients are connected into the same dumb/unmanaged 8-port GigE switch.

    I'm able to copy a video file from the RPi3+ SD card over Samba to the Win 7 PC at a sustained rate of about 42MB/s - this basically maxes out the 3B+ network connection, which is the bottleneck.


    Copying the same file from the Win7 PC to the RPi3+ (to the SD card) copies the file at an average rate of about 30MB/s as now the SD card is the bottleneck (it can't write any faster than about ~25-27MB/s).


  • I'm using a Class 10 Sandisk and a Class 10 Samsung, 16GB and 32GB in my two units. The graph was copying a video file to the Pi via unmanaged GbE switch. The issue is not max speed, 20MBps is spec. The issue is the constant dips down to 0. I do not experience this with Workstations on the same network.

    I'll test some more and possibly explore different SD cards.

  • Tested the new 8.2.5. still not ok :(

    Millhouse, can you please send me that 9.x version of your image file please?

    And how can I raise speed above from 11 mbps on windows 10?

    What component is slow on my rpi3b+?

    -sd :class10 sandisk

    -maxtor 1tb external disk usb3 60mbps speed when connected to pc (maybe this? cos only usb2 on pi?)