Stay to LibreELEC logo with W95

  • Hi,

    I have a W95 box with S905W SoC and 1GB RAM

    I tried to use LE on this box but I have an issue.

    I use 8.90.6 with S905W 1GB device tree (tried both), boot from SD, LE resize the storage then reboot. After reboot, it stays to LibreELEC logo for a while then reboot so I can't access to LE.

    If I use S905X device tree, I get a black screen.

    Any idea ?

    Thank you !

    Edited once, last by NicCo ().

  • Hard to say what the issue could be here.

    Are you sure the device is 1GB, probably a stupid question.

    Have you tried using an 8.2 build with the S905X dtb?

  • Yes I'm sure, I have 2 boxes like this and I have tried both. I've checked from Android 7.1 already installed.

    If I try S905X dtb +, it doesn't work, it doesn't boot and I get a black screen (same issue with 8.90.6 + S905X dtb).

    Thank you.

  • I've found the dtb from a firmware for my box, I hope it could help you.



      (20.52 kB, downloaded 390 times, last: )
  • Is it possible to use this dtb or do you need to modify it in order to work with 8.90.6 ? Thank you !

  • no you can not use it, it may help explain why you can't boot though, I will take a look when I get chance

  • OK thanks, perhaps I'll send it back to Amazon because I'm not sure it will work in the future...

  • Do not rely on the manufacturer's information. Try to use gxl_p281_1g.dtb or gxl_p281_2g.dtb

  • OK thanks, perhaps I'll send it back to Amazon because I'm not sure it will work in the future...

    If you do send it back, get one of the many supported devices, the older S905X devices are best but cost a little more than an S905W one

  • Yes I'll go to S905X, I already own some S905X boxes and it work very well, even with 1Gb RAM.

    If you want to do some test before I send it back, please tell me, I must send it before the middle of the april month.

  • I had it working same model but with 2gb ram. Lent it to a friend so can t check but I'm sure i followed the guide for device tree and worked straight out of the box.

  • Very strange, I've tried 2 box and both don't work. I've tried to flash older firmware (704N0, 705N0, 706N0) but same issue. No problem with any S905X box.