How to transfer files from OS X to Libreelec

  • Hi. I am struggling with transferring files from my OS X 10.13.3 machine (High Sierra) to Libreelec. I've tried Samba. The transfer stops within minutes. I/O error -36 (if I am correct). My network is stable. No packet loss.



    I tried SFTP with Forklift. Doesn't work. Then I downloaded FileZilla. It doesn't work either. If I hope terminal on my Mac it connects, but I can't transfer files that way. I am trying to transfer a 16 GB file to the local eMMC. I don't have an external drive.



    Is there any solution to this problem? Thanks

    EDIT: been looking at this again, and it seems that I am actually connected, but how can I transfer a file? No folder shows up on the remote site window/tab.

  • I'm not sure why Samba wouldn't work, but SFTP works with no issue. Make sure you enabled the SSH service as it is disabled by default.

  • I've never been able to transfer big files from Mac to Libreelec through Samba. I have been trying different laptops, and also different kodi boxes. One s905x and now on my S912. It works from 1-5 minutes, then I get an I/O error. I tried to use Samba 1, but I couldn't connect.

    Got SSH working now. Tried enabling/disabling it several times. Very weird. Speed = 900 KB/s. File = 16 GB. 1 Gbit full duplex...