LibreElec OVA image does not allow connection to Kodi Addon Repository

  • I hoping someone can help me in this forum.

    I recently tried importing the LibreElec OVA VMWare image and using it to test Kody Addon's before installing to my main media centre.


    I'm using VMWare Workstation 12 for windows and have tried importing both LibreELEC-Generic.x86_64-8.2.3.ova and 8.2.4.ova. Both seem to have the same issue -- when I try to access Kodi Addon Repository it gives me the following error message "Could not connect to Repository". Does anybody know what the issue is? Am I doing something wrong?

  • pls remember that you need to enlarge your hdd (at the vm setting) before the first boot or you have an very very tiny storage drive

  • Habe you assigned a bridged Network in VMware Network Manager?

    I left the default which is Bridged Network. I tried all the other network options and no success.

  • pls remember that you need to enlarge your hdd (at the vm setting) before the first boot or you have an very very tiny storage drive

    yes I did this before first boot. Expanded to 16gb.

  • You must go to Network Manager and Say which Network Card to Use. Furthermore you have to bridge them and press apply

  • you have there "Host only" -> no internet

    thanks seeing that. It was leftover from my previous attempt. But I had been trying to with the default Bridged option.

  • I've been able to resolve this issue by upgrading my VMware player from 12 to 14. When I did that it came up as black screen. Doing some googling I realized I have a VPN active on my windows laptop. Once I deactivated the VPN and rebooted VMware the screen was not black. I started the LibreElec image and it picked up the internet connection and thus I was able to connect to the Kodi Repository inside the LibreElec virtual image.


    Thanks to all for your help!

  • pls remember that you need to enlarge your hdd (at the vm setting) before the first boot or you have an very very tiny storage drive

    I'm just attempting to do this and ending up with a 30MB storage partition. Can you advise how I go about expanding it? VMWare Workstation doesn't seem to let you change the size before import.

  • Delete your LE VM, import the LE ova again, then after import go to the vm settings-hdd and there is somewhere a possibility to expand the hdd. After resize start the VM. LE only resizes the hdd at the very first boot, you can't do it if you booted already one time.