Frequent crash with Librelec 8.2.2 on Odroid c2

  • I am experiencingin almost daily crash (when I am not watching!!) with Librelec 8.2.2 on Odroid c2.

    I don't know how am I supposed to debug this, specially with a SIGBUS empty !!


    here is part of the log, any idea pls


    ############## kodi CRASH LOG ###############

    ################ SYSTEM INFO ################ Date: Mon Feb 26 02:55:27 EST 2018 kodi Options: --standalone -fs --lircdev /run/lirc/lircd Arch: aarch64 Kernel: Linux 3.14.29 #1 SMP PREEMPT Fri Dec 22 15:09:58 GMT 2017 Release: LibreELEC 8.2.2
    ############## END SYSTEM INFO ##############

    ############### STACK TRACE #################
    =====> Core file: /storage/.cache/cores/core.!usr!lib!kodi!kodi.bin.1519631693.570 =========================================
    [New LWP 570]
    [New LWP 3632]
    [New LWP 578]
    [New LWP 585]
    [New LWP 3620]

    ...

    [New LWP 691]
    [New LWP 3654]
    [Thread debugging using libthread_db enabled]
    Using host libthread_db library "/usr/lib/libthread_db.so.1".
    Core was generated by `/usr/lib/kodi/kodi.bin --standalone -fs --lircdev /run/lirc/lircd'.
    Program terminated with signal SIGBUS, Bus error.
    #0 0x002f636973756d2f in ?? ()
    [Current thread is 1 (Thread 0x7f90586000 (LWP 570))]

  • I am experiencingin almost daily crash (when I am not watching!!) with Librelec 8.2.2 on Odroid c2.

    I don't know how am I supposed to debug this, specially with a SIGBUS empty !!

    I'm "happy" I'm not the only one seeing this issue. I'm experiencing these crashes since months on five different devices (generic Intel, Raspberry Pi3, vero 4k), with LibreELEC and with OSMC.


    Thread on kodi.tv and crashlog.


    Even see this when I only boot a system and let it on its own.

  • 8.2.3 didn't help much :-(

    Yes, I'm also seeing it with 8.2.3. Maybe you could bring this to the kodi forum as it is not a libreELEC specific problem. I also got it with OSMC when I was still using it. It is a very nasty issue as I still do not understand what is triggering it (maybe some race in kodi code or one of the libraries used). I tried a lot of things such as using different skins, removing all unneeded addons, but did not succeed getting rid of these (almost) daily crashes.


    What puzzles me most: There are so many kodi/libreELEC users and it seems nobody else is affected by this problem. In fact you are the only one besides me I'm aware of. This is why I'm so glad I'm no longer alone, as the kodi people probably must assume it is me who is doing something wrong, which is quite understandable. Of course chances are others are also affected but do not notice it because they are not checking their logfiles and the crashes seem to happen only when the system is idle. I only know it is not defective hardware as it happens on several different devices even with different architectures.

  • Anyone having crash issues on Odroid C2, the first thing to look at is to see if you have a power source enough to run Odroid. Make sure it is has at least 2A output. I was using a power source with 5.2V - 1.35A output and had a lot of issues with buffering and it kept crashing, freezing. Changing the power source with a 5V - 4A kodi is much more responsive and no crashes at all. Hope this helps some of you.