LED (VFD) Displays in LibreELEC

  • Thanks man. Sorry for lack of concentration, here it is in attachment.

    Files

    • dtb.zip

      (27.69 kB, downloaded 88 times, last: )
  • If i understand correct, this dtb which i extracted from Android, i cannot use it with LibreElec. So i download dtb.img file from here


    I attached dtb.img file which i intend to use.

    Files

  • Axee I needed the Android DTB to see what the display configuration is, so that a matching vfd.conf file could be created for the device.

    I'll look at it later today.

  • i tried, i puted this vfd.conf file you provided in /storage/.config/ folder, but nothing happend. It displays ''boot'' same as before.

  • Axee you need to use an LE build that has a recent version of the "openvfd" driver baked in. And of course use a DTB provided for that specific build.

  • @Coolest I have not tried it yet because it happened yesterday, but I will let you know as soon as the results come out. Thank you.

  • onexzero Thanks.

    From the looks of it, the vfd.conf I suggested should work just fine.

    The display looks identical, and so does the DTB configuration.

    Please let me know if it works, and I'll update the file in the repository to include the U5X+S as well.

    Hi

    I tested with vfd.conf and gxm_q201_3g.dtb yesterday, but nothing appears on the display. It just appears black. I attached dmesg log for reference. The lsmod result shows that aml_fd628.ko is loaded. I think I am doing something wrong. Thank you.


    I checked configuration again..

    Installed image : LibreELEC-S912.arm-8.2-8.2.2.3.img.gz ( I can't use LibreELEC-S912.arm-8.2.4.1.force.444.10bit.img.gz <-- Freezing on boot logo)

    FD628Serviice running.

    aml_fd628.ko loaded.

    vfd.conf - /storage/.config

    Anything else???

    Files

    • dmesg.txt

      (95.78 kB, downloaded 129 times, last: )

    Edited once, last by onexzero ().

  • Hi, I have a Magicsee n5 and using the files in post #389 the display does not work. The module load correct and the vfd.conf file too. But the display do not turn on. May be its a new version of N5? This is the dtb extracted from Android. The spec are s905x 2Gb Ram 16Gb Rom.


    Thanks!!!!

    Files

    • dtb..zip

      (193.72 kB, downloaded 69 times, last: )
    • dmesg.txt

      (2.33 kB, downloaded 78 times, last: )
  • salavert69 I'm not sure what the issue is with the N5 boxes and the VFD driver.

    I had a report say that after booting up Android, and then rebooting back to LE/CE, it would work.

    I don't have this box to do hands-on debugging, so it's pretty difficult to guess what is wrong exactly.

  • The Coolest No, not really. When the box is turned off, the display is off, too (that's a progress, before it was showing "boot" the whole time).


    When the box is turned on, the display just shows some random "-" signs and the Pause-icon is blinking (it does not matter if a video is running or a menu is on the screen).


    Any ideas?


    Thanks!