Remote power trouble

  • Quote

    data about DDR memory

    What data exactly?

    Quote

    dtb file

    The Android one?

    Quote

    remote factory_code and power key scancode

    Would the data in the Android remote.conf do any good?

    bumerc

  • I've just done...

    booted libreelec, erased bootloader,

    rebooted with second sd card prepared with:


    sudo dd if=u-boot.bin.sd.bin of=/dev/sdX bs=1 count=442 && sync

    sudo dd if=u-boot.bin.sd.bin of=/dev/sdX bs=512 skip=1 seek=1 && sync


    but is not working....seems a problem with ddr4 memory... this is the log:

    i've restored Android with amlogic usb burning tool.


    Maybe i need a different u-boot.

  • ok., please test this version

    u-boot.bin.sd.bin_clk_792Mhz


    tip:

    when reinstall - fill the space for the u-boot with zeros

    Code
    dd if=/dev/zero of=/dev/sdX bs=1 count=442
    dd if=/dev/zero of=/dev/sdX bs=512 skip=1 seek=1 count=2047

    then

    Code
    dd if=u-boot.bin.sd.bin of=/dev/sdX bs=1 count=442 && sync
    dd if=u-boot.bin.sd.bin of=/dev/sdX bs=512 skip=1 seek=1 && sync

    Edited once, last by bumerc ().

  • So,

    what do you need to devise an u-boot image for the green CZ-S32-V2.2 H96Pro+?

     

    for the tests:

    [email protected]

    [email protected]


    -Added support for RGMII interface, since all versions of the X96Pro + boards use the H5007NL 1000BASE-T module

    -For the correct functioning of the network connection, you must use gxm_q200_3g.dtb file


    Here is the modified file for devices with 3Gb RAM, for LE kernel


    gxm_q201_3g.dtb.zip


    The bootloader has not been tested, use at your own risk!

    Edited 2 times, last by bumerc: refreshed link ().

  • hi, i ve a H96PRo+ with Blue PCB CZ-S32-V5 (3gbram) with 1glan

    Using LibreELEC-S912.arm-8.90.6.img and booting from an 32gb USB Stick.

    When power off i cant use the remote to turn it on again :(


    what can i do , so, please can me give somewhere an install instruction?



    ps:what dtb.img must i use to using 1gb lan, my fritz box shows only 100mb..?

  • look here


    - i have updated u-boot binary

    Quote

    -Added support for RGMII interface, since all versions of the X96Pro + boards use the H5007NL 1000BASE-T module

    -For the correct functioning of the network connection, you must use gxm_q200_3g.dtb file

    1. Go through the installation instructions.

    2. Before you write u-boot.bin to the emmc memory, replace the dtb.img file with gxm_q200_3g.dtb in the / flash directory and rename it dtb.img again. Then replace existing u-boot.bin by updating version and follow the installation instructions.


    download

    updated [email protected]

  • My board with DDR4 hangs at boot also with this u-boot... restored with Amlogic USB burning tool full restore.

  • gulp79

    No Log = No Help

    Sorry, i've tried the u-boot update without connecting serial (hoping in good luck).

    As soon i've some time (my son use the box every two seconds....so i've to try at nigth :dodgy: ) i'll upload your u-boot (ddr4) and i'll provide you the log.

    In meantime, i've solder the pins to onboard serial port, so i can connect a lot faster nowI

    Thank you for your support!

  • gulp79

    before you go to sleep.. please test the next build:shy:

    u-boot_chl_auto


    Ok,


    i've prepared SD2 (/dev/sdf)


    burned your "LibreELEC-S912.arm-8.90.6-h96pp-emergency-sdcard.img"

    copied "gxm_q201_3g.dtb" (and after i've tried also gxm_q200_3g.dtb") over dtb.img

    then injected u-boot.bin.sd.bin into SD2



    After i've done a boot with SD1 (my libreelec sd card),

    erased bootloader

    Code
    dd if=/dev/zero of=/dev/env bs=8M count=1 && sync
    dd if=/dev/zero of=/dev/bootloader

    then rebooted with SD2


    this time u-boot starts, but the emergency systems dosn't boot, this is the UART log:


    so i cannot write new u-boot.bin to eMMC.......


    a little better than previous attempt

  • seems that using dtb for 2Gb of ram make the difference.

    So Booting with gxm_q201_2g.dtb or gxm_q200_2g.dtb is ok, i was able to write uboot to /dev/bootloader


    now i can boot the (old) SD1 and my remote can shutdown and poweron my Alfawise H96 Pro+ 3Gb

    but i've only 2 GB =O


    So, somenthing in new uboot cannot detect all my ram.

    bumerc , do you think is possible to fix also this problem so boards with 3Gb can use all available ram?

    For now, thank you!


    In attachment there is the UART log of my board booting from u-boot from mmc and load libreelec from SD1, hope you can find the problem.

  • gulp79


    Rank1 (1024MB) could not be initialized, i will see what I can do.

    What is the size of the single RAM chip - 12x8, 13.2x9 or 14x9 mm? Please measure on the front and on the back of the PCB.