TVHeadend HTSP Client: couldn't be loaded

  • Hello, I attempted to transfer my aarch64 box (LE 8.2.1) to a s905 box (LE The only problem I've found it the TVHeadend PVR client is not loading.

    Seems to have to do with the architecture? Found this in the logs:

    wrong ELF class: ELFCLASS

    Not sure if it means anything. The log file is after a clean boot.

    Error message is:

    Add-on couldn't be loaded.

    Can't load shared library

    Log shows:

    ERROR: Failed to read 'zip://'

    19:01:19.829 T:3861902240 ERROR: Unable to load /storage/.kodi/addons/pvr.hts/, reason: /storage/.kodi/addons/pvr.hts/ wrong ELF class: ELFCLASS64

    19:01:21.562 T:3861902240 ERROR: UpdateAddons - failed to create add-on Tvheadend HTSP Client, status = 6

    19:16:56.089 T:4097771616 ERROR: Unable to load /storage/.kodi/addons/pvr.hts/, reason: /storage/.kodi/addons/pvr.hts/ wrong ELF class: ELFCLASS64

    19:19:56.019 T:4097771616

    Edited 2 times, last by Kick4U ().

  • Binary add-ons compiled for aarch64 will not run on an arm build. You need to remove and reinstall pvr.hts.

  • Tried uninstalling and reinstalling yesterday.

    Just tried to reinstall and now kodi won't install anything from LibreELEC's repository! Tried deleting the pvr.hts from /addons/packages/ but still wouldn't install.

    Found raybuntu Odroid arm version and all is working.

    Now I need to figure out why kodi stopped allowing installs from LibreELEC's repository?

    Edited once, last by Kick4U ().