NUC6CAYH pulls too much data from NAS?

  • Hi.

    Got a new NUC6CAYH for christmas, and i have spend the whole day setting it up and playing around with it. Using LibreElec 8.2.2.

    I have some trouble with it though.

    When i try to watch a 4K bluray from my NAS, it stops only few minutes after it started. When i try to skip like 10 minutes it also stops and can almost not run, and keep start/stop.

    If i at the same time look at my NAS (Synology DS214play) it look's like it's very busy delivering data to the NUC.

    The maximum transfer speed on a gigabit network should be around 125 MB/s, but according to the NAS my NUC is pulling much more data.

    If we are looking at the file we are trying to play it's around 45 GB, and 90 Minuts long, so it should only pull 8-9 MB/s from my NAS.

    Because of the trouble i tried to transfer the file from my NAS to the NUC's built in SSD, using filemanager in KODI. When i try that the transfer speed according to the NUC is 9-12 MB/s which again is too slow on a gigabit network. But when i look in the NAS interface it still tells me the transfer speed is way higher than it should be like in the picture.

    What I have tried so far:

    - Transfering from my NAS to my Macbook Air (wireless). When i do that my speed is around 30 MB/s, and when i at the same time look in the NAS's web interface it also tells me 30 MB/s.

    - Tried both SMB and FTP.

    - Tried Wireless connection on the NUC. The speed increased to around 15 MB/s, but the NAS still shows odd numbers.

    - Tried to transfer a file from my Macbook Air to the NUC's built in SMB server. The speed was around 10 MB/s.

    I can't find anywhere to see the Wired link speed in Libreelec, but when i look at the NUC i can see there is a green light which should indicate gigabit connection. I have also tried 4 different cables which did not make any changes either.

    Have you guys any idea what the problem could be?

    • Official Post

    Peaks of 500 MB/s is a bit... enthousiastic in my view. :)

    On paper, gigabit does 1,000 Mb/s, meaning 125 MB/s . In reality counting in the network protocol overhead, a 115-120 MB/s constant throughput would be the absolute maximum. NFS is the one with a leaner overhead, thus should be smoother than SMB. However, your mileage may vary.

    Perhaps you have set a higher MTU size, which might show a different speed graphic, but afaik gigabit cannot be "turbo-boosted" to 500 MB/s.

  • Peaks of 500 MB/s is a bit... enthousiastic in my view.

    Correct, but my KODI Box just says 10 MB/s, so why does the NAS tell me up to 500MB/s?

    That's the strange thing in this. MTU is set to 1500, so that should be fine.

  • Correct, but my KODI Box just says 10 MB/s, so why does the NAS tell me up to 500MB/s?

    That graph must be wrongly implemented or scaled. Do you know if the os is up to date?

    If you're familiar with grafana/influxdb you can try to set up a telegraf daemon to collect stats using snmp in your NAS then use grafana to compare the bandwidth rates against the ones provided by the synology OS

  • I think the Graph is up to date, it shows almost 100% correct on all other transfers.

    I have done some further testing from another NUC i got.

    Here i got close to 20MB/s, but again that is not much.

    When I download with 20MB/s with my NUC from my Synology shows the stats in the Synology 3-500 MB/s. I then download the same file with my Macbook Air from my nas over Wifi with around 30 MB/S and my Synology shows 30 MB/s.

    I have also tried with OpenElec but that made no difference.

    Is it possible that you could try and check how much you can download with from your NAS?

    It's only something that happen when is KODI.

  • I have at the moment only 4k samples not full 4k Blu-rays. I can test with my nas it has collectd and telegraf collecting stats.

    I think libreelec wouldnt make a difference because the nas is using his nic stats to graph bw.

  • These are graphs on three 4k samples playback

    This is the server using rrdgraph

    Same server using grafana/telegraf

    This is kodi network interface graph also grafana/telegraf

    The samples are


    LG_CHESS_HDR and


    They are around 40-60Mbit/s bitrate files

  • But it is still the graph that is wrong... You have a 1000Mbit/second connection. It is a physical impossibility for you to be getting more than 125Mbytes/second down that cable. As mentioned above, with overheads it will be less than that. Even with some traffic in both directions it will still be less than shown. The graph software seems not to like the way that Kodi fills and maintains the buffers while playing, but it's still a problem with the graphing software, not with Kodi.

  • Hi.

    Thanks to all answers.

    I know 100% for sure that the NAS is not transfering 500MB/s, and i know that is way over the limit of the network, nas and NUC as @S80_UK mention.

    I just mentioned it as a symptom on my main problem, which is my NUC only transfering maximum 10 MB/s from my NAS which is not enough for stable streaming when the bitrate is hitting 80-90 Mb/s.

    I was thinking about reaching out to Synology, but again the problem only appears when i try to transfer from my NAS.

    @subzero79 I am curious. What is your maximum speed if you download the file to your Kodi Box?

    The problem is not actually the graph in Synology's webinterface. The problem is that i can't stream movies from my NAS to my NUC without it stops and buffer, and beside of that it takes forever to fill up the built in SSD with movies which i sometimes do for a weekend trip to a vacation house we sometimes use.

    Edited once, last by SGADK ().

  • OK - so ignoring the graph problem, have you tried another cable? Are you sure that the cable you are using is allowing a 1000Mbit/sec connection to the NUC? A faulty cable may still work, but might only allow a connection at 10 or 100Mbit/sec.

    • Official Post

    Faulty or low standard cables can hinder the handshake between ethernet cards. A good cable should have no trouble creating the highest connection possible. You could try to force a gigabit connect, but find a different cable first. Also try different ports on the router/switch.

  • As i mention in the topic i have tried 4 cable, all is Cat5e, and the link turns green indicating 1 gig connection.

    I have also tried wireless, it's the same but give slightly more. Around 15MB/s over 5Ghz AC network.

    I don't think this is a hardware failure to be honest.