EPG Time is one hour off after daylight savings time ends

  • My epg has been off by an hour since we switched back to standard time.

    I've tried uninstalling the nextPVR client and clearing the guide databases, rebooting and then installing nextPVR. The epg time is correct until I reboot Kodi and then it goes back to being one hour off.

    Here's a link to my log: Kodi log (epg issue) 11/12/17 - Pastebin.com


    By the way, I am running Kodi on 2 Raspberry Pi systems and only one of them has the epg time problem.

    Their configurations are the same except one has more addons than the other and of course they are connected to different TVs.

    The one with the additional addons is the problem child.


    I'm in the U.S. eastern time zone and have never had this problem before. Any suggestions for resolving this issue will be greatly appreciated.

  • On each system, please give us the output of the date command. (you need to ssh in for that, I assume you know how to do it).

  • Le2:~ # date

    Mon Nov 13 07:32:15 EST 2017


    Le3:~ # date

    Mon Nov 13 07:33:42 EST 2017


    Le3 is the problem child

  • I can see that LE3 was original an OE install .. there's a ton of unnecessary language resources and unofficial repo junk that's been pre-installed. It really wouldn't hurt to take a backup and then reinstall.

  • Thanks for your advice.

    Actually both systems were originally OE. I made a backup of the OE system, created a fresh install using your SD creator app and then restored from the backup.

    Is there a way to get rid of those unnecessary language resources? I assumed they were dependencies associated with other addons.

  • You need to manually unpack the backup tar file and selectively restore items else the "full restore" process is reverting the box to exactly the same state it was in before reinstalling, i.e. nothing changed.

  • Problem Solved:

    I compared my 2 RPi systems and found that the problem child had an LE setting the good system didn't have: a timeserver setting. I've removed the timeserver setting and have rebooted the problem child 6 times and each time, the EPG time was correct.

    Background:

    RPi systems do not have a clock so when the internet is down, an RPi shows the time it was the LE software was compiled. My solution to this problem was to turn my back end NextPVR server, a Windows 10 desktop PC, into a time server for the RPi since it has a clock. The solution appeared to work well until Daylight Savings Time ended. I don't know if the problem would exist if I had specified an external time server. What I do know is that specifying the windows PC as a time server is problematic.

  • I don't know if the problem would exist if I had specified an external time server.


    I've just experienced this same problem over the weekend since the UK clocks went forward 1 hour for BST.


    I am running Kodi v17.6 on LibreELEC v 8.2.3 with Tvheadend v4.2.5, with the pvr.hts client on the same machine.


    I have not touched the LibreELEC time server settings, so it's using the standard internet time server that ships in the LE settings by default.


    On Saturday (when we were on GMT), I was looking ahead in the TVGuide as I wanted to schedule a program that started at 07:30PM on Monday 26th March. However, the TVGuide was showing the program as starting at 06:30PM. I then realised that this was probably because the clocks were changing Saturday night/Sunday morning, so I didn't worry.


    However, on Sunday morning, following the Daylight saving changes, I went to look in the TVGuide again and everything was still out by an hour including the programs currently playing. The system time, which is also displayed top-right of the TVGuide had been changed to reflect the DST, so this was correct. However, the TVGuide data was all out by an hour e.g. a show which started at 11AM was actually showing as having started at 10AM, so the timeline which goes vertically down the screen was therefore over whichever program would be playing in 1hr time.


    To correct this I went into Kodi Settings -> PVR & Live TV -> General -> Clear data. The database was cleared and refreshed from the Tvheadend backend (as mentioned, this is on the same machine). Following this, all the times were then correct. It would be nice if we didn't have to do this whenever the clocks change.

    Edited once, last by jahutchi ().