[___] NVIDIA Optimus - LibreELEC 8.2 with NVIDIA Corporation GK208M [GeForce GT 730M]

  • Hello,

    the syslinux.cfg

    The addition "nouveau.modeset=0" will not solved the problem.


    Edited 2 times, last by liberi ().

  • How can i onliy use the Mesa DRI Intel(R) wiht LibreELEC 8.2?

    To use intel graphic - like

    cp /etc/X11/xorg-i915.conf /storage/.config/xorg.conf

    and blacklisting nvidia.

    Or maybe nvidia-legacy should be used? Worth a try.


  • Hello, i have make a new LE 8.2 USB Stick.

    Than i boot LE 8.2 "live" modus, no problems.


    cp /etc/X11/xorg-i915.conf /storage/.config/xorg.conf

    The /etc/X11/xorg-i915.conf is total empty, no content.

    The /storage/.config/xorg.conf to.

    LE 8.2 booting in the "run" modus, i get the "GPU: Mesa DRI Intel(R) Haswell Mobile" driver.

    Shutdown LE 8.2, booting again, and the xorg will not start.

    Where and how can i disable nvidia?

    Did LE 8.2 the nuoveau oder nvidia driver as default?


    Section "Device"
    Identifier "Device0"
    Driver "intel"
    VendorName "INTEL Corporation"
    Option "TripleBuffer" "false"
    Option "TearFree" "false"

    Edited once, last by liberi ().

  • Where and how can i disable nvidia?

    For the "run" mode mount the second partition on any linux OS and create the empty file as as root:

    true > "mount point"/.config/udev.rules.d/96-nvidia.rules
  • Hello, new test.

    Created a new LibreELEC 8.2 with:

    sudo ./LibreELEC.USB-SD.Creator.Linux-64bit.bin

    With "gparted" i have rezided the second partition "primary.

    Now i boot the LE 8.2 stick first, LE 8.2 checks the filessytem.

    Than i start Lubuntu 16.04 LTS, i mount second partition "primary.

    Created 96-nvidia.rules:

    sudo nano /media/liberi/56757c16-5918-4dbc-9fd8-415ad033157d/.config/udev.rules.d/96-nvidia.rules


    sudo su
    true > /media/liberi/56757c16-5918-4dbc-9fd8-415ad033157d//.config/udev.rules.d/96-nvidia.rules

    What did i do with "rue > "/media/liberi/56757c16-5918-4dbc-9fd8-415ad033157d//.config/udev.rules.d/96-nvidia.rules" ?

    Why can not I just do it as admin? I must login as "root"?

    Now i boot LE 8.2 an LE 8.2 is working fine.

    I will testing more time.



    If i boot LE 8.2 "live" and the "run", the xorg server will not start.

    Now i will create log files.

    Edited 5 times, last by liberi ().

  • ----------------------------------------------


    If i boot LE 8.2 "live" and use the "run" modus, the xorg server will not start.

    xserver will not start.

    It will not work at every boot.

    Thank you, vpeter

  • What did i do with "rue > "/media/liberi/56757c16-5918-4dbc-9fd8-415ad033157d//.config/udev.rules.d/96-nvidia.rules" ?

    Why can not I just do it as admin? I must login as "root"?

    The file overrides /usr/lib/udev/rules.d/96-nvidia.rules and as empty file disables loading the drivers for nvidia graphic cards.

    LE only uses root (UID 0/GID 0). Being it prevents any issues.

  • Hello, i will try it again.

    I have boot the run modus, xorg server will not start and get this error logfile:

    Perl Nopaste

    08:56:28.169 T:139752820583744 NOTICE: Log File is located: /storage/.kodi/temp//kodi.log
    08:56:28.169 T:139752820583744 NOTICE: -----------------------------------------------------------------------
    08:56:28.174 T:139752820583744 ERROR: DBus: Error org.freedesktop.DBus.Error.ServiceUnknown - The name org.freedesktop.UPower was not provided by any .service files
    08:56:28.176 T:139752820583744 NOTICE: load settings...

    Now i do this:

    [___] NVIDIA Optimus - LibreELEC 8.2 with NVIDIA Corporation GK208M [GeForce GT 730M]

    The xorg server is starting

    This is the log file:


    LE 8.2 in the run modus will work fine. I have ssh connect.

    If i boot now "live-modus", the xorg server crashed, i have no ssh connect.

    Edited 8 times, last by liberi ().

  • Forget the "live" mode. It always starts with an empty /storage RAM disk file system and no configuration is possible.

    Enjoy the working configuration.

  • Thanks to @\x from irc this is the solution.


    17:13 <\x> true > .config/udev.rules.d/96-nvidia.rules

    17:13 <\x> ^ that did the trick

    17:13 <\x> so basically that + turn off lvds1 at boot

    17:14 <\x> tho this is with intel igpu

    17:14 <\x> but yeah, as long as it works, I'll take it


    17:32 <\x> heres my /storage/.config/autostart.sh 2ro5

    xrandr --output LVDS1 --off
    xrandr --newmode "3840x2160_24.00_rb" 210.62 3840 3888 3920 4000 2160 2183 2188 2194 +hsync -vsync
    xrandr --addmode HDMI1 "3840x2160_24.00_rb"
    xrandr --output HDMI1 --mode "3840x2160_24.00_rb"