SMB with Libreelec 8.2 and TimeCapsule not working

  • Hello,


    I'm trying to use my Time Capsule but impossible.

    I am on Librelec Milhouse #0429.

    I tried everything.


    This first method but not working so I don't know if I'm doing well : I created a file storage.timecapsule.mount with the code and put the file in /storage/.configfiles/system.d/ and /storage/.configfiles/sysctl.d but nothing after reboot.


    Quote

    Save that ^ as /storage/.config/system.d/storage.timecapsule.mount then "systemctl enable /storage/.config/system.d/storage.timecapsule.mount" and reboot, and the local mount to the device should be available to add as a new source in Kodi. It appears to be stable for me over a period of several hours. If 'mount' works the issue appears to be in smbclient or how Kodi interacts with smbclient.



    This second method, but not working too : I created the file autostart.sh and put it in storage/.configfiles. I reboot but nothing.


    Quote
    Bash
    #!/bin/sh
    (sleep 10 && mount -o remount,discard /flash && mount -o remount,discard /storage && mount -t cifs //192.168.1.128/Data /storage/timecapsule -o username=MyUsername,password=MyPassword,unc=\\\\192.168.1.128\\Data,sec=ntlm,vers=1.0)&


    Is there someone could me explain step by step how to do it because I don't understand why it's not working for me..


    Thanks a lot !

  • Chewitt,


    Thank you for your answer. I renamed storage.timecapsule.mount with storage-timecapsule.mount on my 2 files in /storage/.configfiles/system.d/ and /storage/.configfiles/sysctl.d But still nothing...

  • I reboot the whole OS.

    systemctl status storage-timecapsule.mount :



    So I just did this : systemctl enable /storage/.config/system.d/storage-timecapsule.mount


    I have this :


    Code
    Created symlink /storage/.config/system.d/multi-user.target.wants/storage-timecapsule.mount → /storage/.config/system.d/storage-timecapsule.mount.
  • I just created a smb folder in storage/.kodi with a file user.conf and this code inside :


    Code
    client max protocol = NT1
    client use spnego = no
    client NTLMv2 auth = no

    Now i have this when I do : systemctl status storage-timecapsule.mount



    And I think that works ! Thanks a lot ! A lot !

    Edited 4 times, last by Darnaga ().

    • Official Post

    OS mounts using systemd have nothing to do with Kodi SMB client configuration in user.conf .. which isn't used at all when accessing the now-local folder at /storage/timecapsule (only when Kodi accesses an SMB share over the network). The same configuration can be done from the GUI btw, if you set max/min to SMB1 and select the "legacy security" option.


    I suspect you just forgot to enable the mount before, which has now been done.

  • Save that ^ as /storage/.config/system.d/storage.timecapsule.mount then "systemctl enable /storage/.config/system.d/storage.timecapsule.mount" and reboot, and the local mount to the device should be available to add as a new source in Kodi. It appears to be stable for me over a period of several hours. If 'mount' works the issue appears to be in smbclient or how Kodi interacts with smbclient.


    Fenderman You will need to rescrape content to the library as all paths to content will change, but at least it works. It is technically possible to update the DB paths but that requires some sqlite SQL skills and I never bothered to learn those. I'm sure there's a howto somewhere.

    Thank you so Much for this solution!

    It's really working, the only problem is that theres a typo on your walkthought. Please consider editing it, so people wont get stuck the same way i did.


    Heres the error:

    "Save that ^ as /storage/.config/system.d/storage.timecapsule.mount"


    This should be

    "Save that ^ as /storage/.config/system.d/storage-timecapsule.mount"


    And again, thank you for the solution, thats really clever