cannot get wireless/BT to work on ECS LIVA-MINI

  • It doesnt seem to cooperate with the device. after i get back i will re start with a fresh install and i will layout a log of steps as i go .


  • I have had success installing the broadcom drivers to Mint linux kernel version 4.8.0-53-generic.

    the installation was performed using the guide shown at the link i have posted below. I DID NOT compile the kernel, it worked after i copied 3 files to /lib/firmware/brcm directory. and ran modprobe to blacklist brcmfmac. i dont have bluetooth, but that is not important (to me at least).

    wireless - I'm running Ubuntu 14.04 and the Broadcom BCM43241 card in my vaio duo 13 doesn't even show up - Ask Ubuntu

    but this is not my goal, my goal being LibreELEC installed with wireless capability.

    I have tried to adding the drivers to LibreELEC , copying the path specified but no changes happen. its the same, no change at all except i have created two new directories. /storage/.config/firmware/brcm.

    the driver works well, i wont know until i test it further.

    i am going to post lsmod and dmesg and paste the links here. i know this can work, i think it would be be done if drop the files into the /firmware/brcm directory. please help me complete this. its kicking my ass. believe me, i appreciate your help.


    JOdi this is dmesg

    cjAX this lspci -nn

    UfTT this is lsmod

    as of this writing i have stopped at modprobe step in the instruction. i going to see if i can get the bluetooth working.

    kind of nervous about messing with it.

    CORRECTION: the file named brcmfmac43241b4-sdio.txt from the ask ubuntu site does run as well as this one, that found that is written for an android-x86 . site below

    android-x86 / device/generic/common / [0fd596] /firmware/brcm/brcmfmac43241b4-sdio.txt

    Edited once, last by Twisted714: CORRECTION ().

  • The following are already present in libreelec

    1. /usr/lib/firmware/brcm/brcmfmac43241b0-sdio.bin
    2. /usr/lib/firmware/brcm/brcmfmac43241b4-sdio.bin
    3. /usr/lib/firmware/brcm/brcmfmac43241b5-sdio.bin

    What is not present is the .txt file, which by the look of it is some sort of parameters for how the device works. So all you should need is the txt file.

    lspci will not show the device, as it is not connected to the pci bus (or the usb bus for that matter).

  • thanks for your help. i cannot get the file installed. i create the directories /firmware and /firmware/brcm and drop the file in the folder via windows smb, but it never uploads the file.

  • chewitt,

    I just understood your last comment.

    i am putting it up right now. the one that works best is the one used on mint. in ubuntu not as well. I didnt install the ubuntu, it came to me that way.

    I have installed the driver to mint several, each time better than the last.

    here is the txt file that works best

    and to driver work, these other files must be in the directory /usr/lib/firmware/brcm/

    those files are here

    Dropbox - brcm_works


  • dropped file into update directory via windows smb.

    it didnt see it. i dont see the txt file in /usr/lib/firmware/brcm it has brcmfmac43241b4-sdio.bin but not brcmfmac43241b4-sdio.txt

    I used the instructions from the link below and had success installing to linux mint . it needs all 3 files that i have uploaded to dropbox above.

    wireless - I'm running Ubuntu 14.04 and the Broadcom BCM43241 card in my vaio duo 13 doesn't even show up - Ask Ubuntu

    these are the steps i used to make it work in linux mint

    copied all three files to /usr/lib/firmware/brcm

    1. modprobe -r brcmfmac && modprobe brcmfmac (run after sudo -i)
    2. iw wlan0 scan

    and it worked

    do you need me to paste anything? lspci, dmesg, etc?


    kodi log VKTG

    Edited 2 times, last by Twisted714 ().

  • I must have been half asleep -as the txt file is in /usr/lib/firmware not the brcm subfolder

    Download again, the test image is updated.

  • ok, the txt is in the correct directory. whats next? i would bet my teeth that the other files i described above need to be there as well.

    or the modprobe command wont work

    here is the log NAJT

    Edited once, last by Twisted714 ().

  • File is updated again - this time with the three files you shared. The two txt files appear to be the same file at different versions (similar but not the same content. Both appear to have references to hardcoded MAC addresses so there is no way we'd embed them as-is into our normal image. It looks like something that should be supported properly within the kernel and not done via copy/pasting.

  • i am on the linux mint install, using the wifi. i cannot figure it out. but i will post any logs you need to compare them and figure out whats wrong.

    this log is dmsg from linux mint with wi fi working

    i do not know what to type to get the system log from mint