LibreELEC on QNAP Nas via Virtualization

  • I have a QNAP TS251A with dual core intel celeron and 8GB of ram. As official Kodi support for QNAP products has been discontinued, i am trying to find another way to have KODI on my nas (which is always on and located next to the TV).


    My nas has virtualization capabilities, allowing the installation of a great variety of operating systems from BSD and linux to win 10. However in order to install an OS you have to provide an ISO of the installation media.


    Here start my problems, as the installation img of LibreElec cannot be mounted on my VM. I tried converting it to ISO with a couple of tools but I cannot boot from it. I have also tried to make a bootable USB, but booting the VM from USB is not possible (I even tried plop boot manager).


    Any suggestions on how to install LibreElec on my NAS?

  • I'm not really sure what you are trying to accomplish.


    If you are wanting to be able to use HW video acceleration you will need to use capable hardware. Otherwise it would be useless.

  • Well, while QNAP provided Kodi for TS-251A, Kodi worked flawlessly, so I guess that the hardware is capable enough.

  • Ok... No need for a Pi as I already have an Apollo Lake Shuttle DX30 dedicated for LibreElec, which works flawlessly. My question was mainly out of curiosity.


    Thanks a lot for your answers!