[SOLVED] Rpi - HDMI Passthrough dissappears

  • Hello,


    I dont know in what exact release, but I cant find HDMI audio passthrough checkbox in configuration anymore. I can choose HDMI as output device, but I just cant find the option to see, if I using software decoder, or HDMI passthorugh. Can anyone explain to me what happened and what I should I do, to enable proper DTS/Dolby passthrough to receiver via HDMI?

    2x VIM3L, 3x X96 Air P3, 6x C2; 6x RPi2; 3x Win7 Kodi + vPeter's mariaDB plugin as Library DB

    Edited once, last by JimmySmith ().

  • Yes, it is expert since installation.. I vividly remember that passtrough was there, but now I cant find it. Before it was System/Audio Output settings, do you have it on the same place? (7.0.2)

    2x VIM3L, 3x X96 Air P3, 6x C2; 6x RPi2; 3x Win7 Kodi + vPeter's mariaDB plugin as Library DB

    Edited once, last by JimmySmith ().

  • The settings level is not on expert by default. So please don't let me get this wrong, if you say "It's expert since installation". Then I have to say "No...after installations it's on 'easy' and you have to set it to". If you did this, then all is fine ;).


    yes it's under system settings->system->audio->passthrough. I just "downgraded" my RPi2 to 7.0.2 to be sure about the location, as it differs by using Kodi 17 because of the skin change.


    Probably you have to scroll down more.


    Get us a screenshot from that screen, where you don't have it. That will tell most.


    Btw....which skin are you using? If you use any other skin than the default one (Confluence in that case) please switch over to confluence first. Maybe it's a skin issue with the skin you use (if it differs from the default one).


    Greetings.