apple Extreme and LibreELEC disk shares

  • Howdy,


    I had to rebuild my setup (which once worked). I am using the latest LibreELEC/KODI with my Apple Extreme (the version with Wireless n). I have 2 hard drives plugged into a powered hub into the apple Extreme. Like I said, it all worked before.


    I believe I had a setup with 'use network password' as the setting in the apple Extreme. I possibly had 'use disk password', but I am certain I did not use "use accounts". I guess there is a permissions bug if you try and use it. Anyways, the best I am able to get is it to show the drives, perhaps let you look once, then ask for a username/pw over and over again. One drive might work, then stop--but the other will never work.


    I had it working in the old network. I would tell you what I did to get as far as I did, but I kept throwing username/password/device settings at the wall to see what stuck so I don't know if I got close. This has been going on for a few hours a night for a few days. Uncle.


    1) Ideas or solutions?


    2) does zeroconfig/bonjour still work? Any ideas how to get it to behave? When It seems to show up, I get the same password loop.


    3) is there a magic 'username' for the basestation share?


    4) I played with SMB://username:[email protected] or name with every combo I could think of.



    Thanks for listening to the rank,



    -Mark

  • If you use SMB as the file protocol, you may want to check the SMB version used on all network devices. LibreELEC now defaults to SMBv2, "thanks" to the worldwide WannaCry pandemic. There is the option to re-select SMBv1 in the LibreELEC Settings add-on.