lib error "was moved" on debian stretch stable and centos 7

  • I have been trying to find a solution for these errors (*warnings*) , with master and libreelec-8.2 branches to no avail. I have cloned LibreELEC, pre-downloaded everything and did "make image"..


    compile [LibreELEC]




    Any ideas any one ?

    The post was edited 2 times, last by bcus ().

  • I tried with Centos 7 and Debian Stretch latest... now i am trying Ubuntu 16.04 because apparently this OS is the one used to compile the public version of LibreELEC. Downloading the packages first and then compiling.


    I have deleted samba package and edited the OPTIONS file within the distributions folder. I don't want it or need it.


  • It's not just about Samba, i like to learn and make things my own in a way that i learn programming and how things work in the process. All previous attempts failed, this is the reason why i decided to just compile without no modifications and to see what happens, i removed Samba because it takes extra time for the build process to finish, and no matter what in the end i wont be using Samba so ya.


    It seems that support isn't much available, just saying turn off samba and use the default image is kind of rude. Lets say you go ask in Kodi forums for support and they tell you, don't do that just use our default image.. anyway. This is open source.

    The post was edited 2 times, last by bcus ().

  • The build process completed successfully on Ubuntu 16.04. I think i will be looking for solutions for the errors (*warnings*) on Centos and Debian directly on those OS forums.


    Real 601m6.733s

    User 719m43.620s

    Sys 154m20.211s

    The post was edited 1 time, last by bcus ().

  • LE is a fairly small project so broad distro support for building is "nice to have" not "must have" and most people use Ubuntu simply because it has a critical mass of LE builders and works, which eliminates the effort of chasing down esoteric build problems requiring deep expertise. Unfortunately the widespread use of Ubuntu means asking for help on "other distro" build issues can be challenging because few people are doing the same and can offer advice. If you do figure things out we are alway happy for people to submit changes on GitHub that improve things!

  • I'm regularly building on Debian Stretch and so far didn't have any problems with RPi or Generic builds.


    Just kicked off clean RPi2 and Generic master builds over night and they worked fine - didn't check for warnings though.


    bcus the snippet you posted just shows some warnings but not an actual error - hard to tell what failed with your build.


    so long,


    Hias

  • You deleted the samba package? The correct way would be to set SAMBA_SERVER="no" in distributions/LibreELEC/options. Otherwise the build process will fail due to missing Samba package.

  • chewitt : yes that's correct. I am a Centos user but I will be using Docker to experiment different Linux Distributions.


    HiassofT : i made the edits on my posts to reflect that i meant to say warnings not errors. For me on both Centos and Debian, the build process seems to "loop" at those warnings therefor the build process never ends and i have to exit the process.


    escalade : yes, i did edit the options file and deleted the package after. I disabled the sftp server at the same time.