Tanix TX3 Mini with Amlogic S905W CPU - Libreelec

  • Apologies for resurrecting this thread, but was anyone ever able to get the Dual-Boot feature to work (Alice + LE) properly with a community build?

    I found playback very choppy, so I tried updating to the last kszaq build. After it had updated, I couldn't use any remote, but I was able to use Kore to test playback which was smooth. Unfortunately, the "Reboot to internal" option has rendered the box useless. It's stuck on the "Tanix" logo now. I figured it wouldn't work, but what I didn't count on was being unable to get into Recovery. Now I have to try and flash it using the Amlogic tools.

    These reboot options, "Reboot to internal" and "Reboot to Android".. Is the function of those options to change the boot flag or something?

  • Hi,

    I've bought Tanix TX3mini 1GB/8GB S905W Android 7.1.2 and do not prosecute FullHD-rips and chipped. It is some possibility to load pure Libreelec + pure KODI. I need step by step manual :-((

    Tanix TX3mini LE

    TX3 Pro

  • Hi, wow,

    i run pure libreelec and pure Kodi 17,6 (LE-s905_8. glx_p212_1g_tx3mini.dtb :-))))

    Fhd 1080p worksfine and smooth , lcd display show only time (its OK) but doesn't work remote controller ....

    I try other image - with gxl_p212_1g.dtb - lcd display show only boot and RC doesn't work .....

    Do you have any suggest/idea - how can I fix remote control.


    Tanix TX3mini LE

    TX3 Pro

  • read this remote.conf repository also, search the forum for the correct device tree, & also search create remote from scratch

    Samsung RU7400 Onkyo HTX22HDX Nvidia Shield HD Homerun Duo (Living Room)

    Samsung UE40ES5500 X96 Max+, Fire TV 4K Stick (Bedroom)

    Synology DS920+ Plex Pass


  • Do you have any suggest/idea - how can I fix remote control.

    Use this #8

  • Hi,

    I have a TX3 Mini with this Dual image flashed on.... LibreElec part seems rather unstable, Android is working ok. How do I reuse the LibreELEC partition, eg. for Batocera ? I'm no rookie with linux/flashing etc, but how is it called from Android ?

  • I can't find the fd628 service addon. I am going into the Install from Repository->Libreelec Repository->Services there is no FD628 service addon. Maybe is it LCDproc?

    Edited once, last by vprasinos: Never mind. I found what I was looking for. I was installing Coreelec on the tanix tx3 mini but information should be updated. The addon we should install for extra icons is OpenVFD and NOT FD628 ().

  • installtointernal does not work. how to correct it

    Please go here for help

    You're not using a Tanix Mini , So why are you posting here ??

  • Dear Members!

    I am new here, but LE not new to me.

    I have exact the same problem as #191 has.

    I have tried _nand and _slowemmc dtb's, but no joy. I have a strange version of this TX3 Mini box.

    It's 1GB/16GB! I am in a very bad situation, 1GB boots, but does not see internal flash.
    2GB version may see the flash but obviously does not boot, as i only have 1G ram.

    Okay, i have figured out that only the ram size, and boot logo location is different in _2g dtb's.

    Looks like I have an unsupported NAND. What can I do?

    Also, this is a new board. TX3MINI-P, 1+16G (8723)

    [    [email protected]] nandphy: Nand PHY Ver: (c) 2013 Amlogic Inc.
    [    [email protected]] nandphy: ######STS IRQ mode for nand driver
    [    [email protected]] nandphy: NAND device id: 2c 84 44 32 aa 4 0 0
    [    [email protected]] nandphy: no matched id
    [    [email protected]] nandphy: get_chip_type and ret:fffffffd
    [    [email protected]] nandphy: get_chip_type and ret:fffffffd
    [    [email protected]] nandphy: chip detect failed and ret:fffffffd
    [    [email protected]] aml_nand d0074800.nand: nandphy_init failed and ret=0xfffffff1

    Looks like it's SpecTek NAND, PFG57, what translates to FBNL05B128G1KDBABJ4-5AF type.
    SpecTek NAND Flash Detail


    Edited 3 times, last by mthqwork ().