Posts by sdf

    Tried new Milhouse builds, but seems that "crazycat tbs drivers" are from "linux-tbs-drivers" repository and not from "media_build" one.

    So in Libreleelec we have three drivers to choose from: normal, media_build (not Crazycat's) and Crazycat tbs.

    Unfortunately neither of them has support for our hdstar v3.

    There's no possibility to include Crazycat media_build in future releases?

    Thank you,

    sdf

    please from stable 5,3 kernel ubuntu 19.10 (or latest 18.04.xx LTS with hwe kernel 5.3 now).


    P.S. 5,5 kernel support some buggy with current media_build

    here it is (ubuntu 19.10 5.3.0 kernel)

    External Content pastebin.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    thank you,

    sdf

    Sorry crazycat,

    do you mean Ubuntu or Libreelec logs?

    btw, tried to compile media_build against latest 5.5 kernel, but it throws this error:

    Everything goes well with 5.3.x and 5.4.x kernels

    Bye,

    sdf

    Compiled media build in ubuntu 19.10 (kernel 5.3.0).

    Seems working well.

    Tuned several stations in Hotbird and no error.

    Anyway will try more deeply.

    Tried also latest Milhouse build, but it seems to me that Crazycat drivers aren't included.

    Can some compile a build with latest Crazycat drivers?

    Thank you,

    sdf

    Hi Aiden.

    I've diff between Updatelee sources and 5.3.1 kernel sources, and found differences in ds3000.c, m88ds3103.c and in particular many differences in dw2102.c.

    Tried only to substitute the .c and .h files but had a compile error.

    Did you find diffs only in ds3000.c with Crazycat drivers?

    Did you examine also dw2102.c?

    Anyway, even if you manage to compile patched Crazycat drivers, how could this be integrated into Libreelec?

    Updatelee drivers work out of the box.

    Could it be possible to add them to the list of addon drivers in Libreelec?

    Bye,

    sdf

    Hi sdf, anything new?

    Thanks.

    Sadly no.

    I've sent a message to Crazycat as suggested by CvH but got no answer.

    What about trying to make a diff between updatelee and crazycat sources (and maybe original kernel and media_build sources)?

    I'm not a programmer nor a great expert, but maybe starting from ds3000 and m88ds3103 sources we will find the culprit.

    What do you think?

    To Danilp.

    Thank you, will try your suggestion.

    Anyway I think this should be solved by making the necessary changes to the drivers, because updatelee drivers work perfectly.

    Bye,

    sdf

    Seems not.

    It's from february 2018 that can't use libreelec.

    Last version that works is 8.2.x

    After that don't know what changed.

    The real problem in Linux (Libreelec) are dvb drivers.

    I bought hdstar because I saw that all said that worked perfectly in linux, but after v3 things changed.

    The real pity is that updatelee drivers work.

    Maybe someone can make some modification to crazycat drivers and make them work?

    Thank you

    sdf

    did you tried the latest LE 9.2 version ?

    pls also try if the crazycat or dvb-latest driver addons work for you (selectable due driver-chooser addon)

    Yes CvH.

    I'm using also daily milhouse builds, and trying all driver addons.

    The only driver addon that works (somehow), only for a few transponders, is Crazycat's.

    With the others (libreelec and media build) hdstar is recognized but can't tune a channel.

    Would like to know if all the others with hdstar have the same problems

    If there's someone that can please help, can post logs with various drivers

    Thank you

    sdf

    Same problem here with version 3 (Geniatech hdstar).

    Only Crazycat drivers work, but only a few transponders.

    All the other transponders are unwatchable (continuity counter error).

    This since Libreelec 9.0 (version 8 worked).

    Hdstar works perfectly in windows and in Ubuntu with compiled updatelee drivers (Chris Lee / v4l-updatelee · GitLab).

    Is not possible to merge or include updatelee drivers?

    Geniatech hdstar is very common. It's a pity that Librelec is unusable.

    Thanks