Posts by HelderCR7

    So I just got a Tronsmart Vega S95x
    Amlogic S905x A53 CPU 2Gb/8GB
    ARM Penta-Core Mali 450MP GPU


    How do I flash this thing with LibreElec? I've done it on my MXIII, my M8S+ without any issues but none of these zip files work; I always get verification failed, or footer is wrong, and installation aborted


    can someone help? I'm thinking I have to get TWRP on this box?? any suggestions?


    Thank you so much and keep up the good work.

    When I use this on my MXIII, MXIII Plus or Tronsmart MXIII everything works except the remotes but then I fix it with remote.conf file copy to /storage/.config


    WLAN, ETHE, BLUETOOTH works fine


    Now on my M8S Plus which has an S812 chip, wifi and Bluetooth do not work


    I'm connected with putty to my box and when I type "ip a" at the command prompt I get:


    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP8000> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether d0:76:58:07:f1:db brd ff:ff:ff:ff:ff:ff
    inet 192.168.0.104/24 brd 192.168.0.255 scope global eth0
    valid_lft forever preferred_lft forever
    3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP,LOWER_UP8000> mtu 1500 qdisc pfifo_fast qlen 1000
    link/ether d0:22:be:06:8c:15 brd ff:ff:ff:ff:ff:ff


    Doesn't this mean WIFI is there? it detects it no? What can I do so that it can see connections and connect? there's no wpa_supplicant file in Librelec is there? if I created one would it go in the .config folder?


    I just want to resolve the wifi issue with M8S+ boxes


    thank you

    I've started from scratch and FINALLY!! lol


    re-flashed Android stock Tronsmart image
    used toothpick method to load Android bootloader, flashed LibreELEC-S802.S82.arm-8.0-devel-update.zip and updated to Kodi 17.0; everything works great even wifi and Bluetooth


    copied LibreELEC-S8X2.arm-8.0.1-S82.tar file to /storage/.update using ssh
    rebooted my box, it updated
    remote didn't work but librelec was there and I can confirm wifi is working and bluetooth!


    copied remote.conf file that I copied from /system/etc/ before flashing to libreelec to /storage/.config


    EVERYTHING WORKS! my god thank you for all the damn posts on this forum and to the man Demetris!

    Hi guys, thanks for all your wonderful tips.


    Have you guys lost the Libreelec under SYSTEM in the main page? I don't have that anymore; so how can I configure wifi and Bluetooth? I can't very anything and my remote doesn't work so I have to use a mouse.


    very frustrating as I never had this issue with 7.0.2 everything worked


    I'm using the file LibreELEC-S8X2.arm-8.0.1-S82.zip as I have an MXIII 2G/8G Amlogic box


    Any help would be appreciated, thank you.

    How come you guys had such an easy time? My librelelec 7.0.2 was working great with 16.1; I put his file in the /storage/.update folder with that .nocompat file I created; rebooted the MXIII 2G/8G and remote doesn't work; I don't have LibreElec in the koFi SYSTEM menu anymore so I can't check for wifi or bluetooth; any ideas of what I did wrong or how to fix this?


    Should I go back to android and start over?


    Thanks
    [hr]


    Hi Demetris ! You latest release works well on my MXIII 2G box ! wifi and bluetooth are ok ! Thanks a lot for your great work ! Have a nice easter !


    Which file did you use? I have the same box did the same thing and don't have wifi or Bluetooth and remote not working.


    Thanks


    Just to be clear, the box is still running android, not LE. Still the same process as above? Does that image support BCM4335 wifi chip set?


    Thanks for the help!


    PS: I can help with the remote, you may need to edit the remote file with the proper device code. I will need to scrape the info together and post it tomorrow.


    If it's still running android get the remote.conf file from system/etc and any other stuff you may need from that folder before upgrading


    I did the toothpick method and flashed the 7.02 first then did the method above as I could not flash with 8.0.1 using toothpick it would fail reading the file every time so I had to get the tar file


    as for the remote, I just need to know where it should go; I mean I took the one right from my android box that worked; why doesn't it work on linux


    I am a refugee from the other S812 builds.


    I have an m8s rounded corner ott s812 2gb/8gb box with bcm4335.


    Which, if any, build can i use? I have also been unable to install any other build since the new releases. Can you please point me to the best set of install instructions.


    Download the tar file corresponding to your android box so the MXIII SX2 file and you need to copy the tar file to /storage/.update


    Also create a blank file in notepad and save it as .nocompat no extension and copy that there as well.


    Once you do that you reboot the box and it will update and you'll have the latest Krypton 17.1


    I easily did this but couldn't get my remote to work even with the remote.conf file


    Good luck


    P.s. I copied the files from windows using the utility pscp.exe so just get that with the IP of your box


    So example pscp.exe (filename) [email protected]:/storage/.update

    Demetris Thank you so much for your efforts, I learn so much every day reading these forums and trying your firmwares; now I have two different boxes


    MXIII 2GB and a clone M8S Plus both with 8GB of space one with S802 chip the other with S812


    I've used both your files for those specific devices, everything works great except WIFI but I could care less as I use LAN but none of my remotes work :(


    I've copied the remote.conf from the android box (before flashing) from system/etc and placed it in the storage/.config folder in Libreelec once it was flashed, rebooted and nothing; both remotes on either device still do not work


    did I do something wrong? I've been at this all day


    For now I'm just using a mouse on both devices.


    As for Wi-Fi do I copy the wifi drivers and wifi config file to the same place to get it working? I remember back in the day with my apple TV 1 I edited the code for wpa_supplicant.conf and got the wifi loaded and working on boot up


    Times have changed of course; any help for anyone would be appreciated.


    Again thank you so much


    lol


    problem is they don't have the stable Kodi 16.1 they have RC3; LibreElec continues support; OpenElec looks like it's stopped


    by the way what's the difference between using the .zip file and a .tar file? can someone explain?


    thanks guys


    thanks for the reply dankec, I used that version on my M8S+ along with other builds of it updated recently but I get no wifi :( I don't understand it


    my M8S+ comes with Lollipop 5.1.1, I know it's an S812 chip


    when I go into the boot loader; I do a factory wipe/reset


    then flash the libreElec 7.0.2


    and its fast and snappy but no wifi

    is there a way to know which wifi adapter my M8S+ has? do I have to go back to Android to do it?


    The linux versions are so much snapier and I can't stand android lol Kodi runs so smooth on OpenElec and LibreElec

    YA makes no sense to me that I can't get wifi; OpenElec has wifi and bluetooth working on my M8S+ but LibreElec does not when I updated to 7.0.2


    any suggestions? what can I do to solve this? Never had issues with the remote though.


    thank you

    Hi have no remote problems at ALL, works great with 7.0.2 on my M8S+


    Everything works fine except no WIFI connections


    Bluetooth appeared and I paired my headset but no WIFI


    I've tried to de-activate and activate the wifi, it says working but then when I go into connections, nothing; ever since I went from OpenElec 6.95.1 to LibreElec wifi hasn't worked


    obviously I switched to have the latest build of Kodi


    Keep up the great work guys, really enjoy what you're doing with the Kodi support; absolutely hate Android "the resource hog"


    Any help would be appreciated.

    Hi have the same problem on my M8S+


    Everything works fine but no WIFI connections :(


    Bluetooth appeared and I paired my headset but no WIFI


    I've tried to de-activate and active wifi, it says working but then when I go in connections, nothing; ever since I went from OpenElec 6.95.1 to LibreElec wifi hasn't worked


    Keep up the great work guys, really enjoy what you're doing with the Kodi support; absolutely hate Android "the resource hog"



    Running M8S+
    GPU Mali-450 MP
    CPU Amlogic Meson8 ARMv7 Processor rev 1(v71)
    Total memory 2 GB
    Kodi 16.1