Posts by Morguito

    Hey guys,

    Currently I'm running Kodi 18 on ODROID C2 through LibreElec 8.90.006 connected on a Denon S930h AVR.

    The problem is, sometimes no audio passes through the hdmi ouput, so I have to go to options and change the output to analog, then it works... But then it uses C2's DAC, which is much worse than the AVR's.

    Do you have any idea about why this is happening? Ideally, Kodi should output digitally all the time and let the AVR do all the decoding hardwork via passthrough...And I believe this AVR is capable of decoding mostly anything.

    It seems to be happening with random video and audio files.

    Any help would be appreciated.

    Thanks

    Hey guys,


    So, I installed Thoradia repo on LibreELEC (alpha).


    Some addons installed just fine, like Medusa and qBittorrent.


    Others, like Jackett, need os.libreelec.tv and tool.mono, which somehow aren't available....In other words: Can't install Thoradia Mono Tools for some reason.


    Here's the log file:


    hastebin


    Cheers,


    Morguito.

    At least the service is enabled and started.

    I still do not understand why this was not done automatically.


    To use the credentials from your Spotify app, delete username/password in the addon settings.

    Ok, so I removed my Spotify credentials, unistalled and reinstalled Librespot, then I've sent journalctl -u service.librespot via PuTTy and this is what I have:


    Nov 07 08:44:51 CoreELEC systemd[1]: Started librespot.

    Nov 07 08:44:51 CoreELEC sh[18061]: INFO:librespot: librespot 582a7b5 (2018-10-04). Built on 2018-10-04. Build ID: 4eE7k6KS

    Nov 07 08:44:51 CoreELEC sh[18061]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:44:51 CoreELEC librespot[18079]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:44:51 CoreELEC librespot[18079]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:44:51 CoreELEC sh[18061]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:44:51 CoreELEC sh[18061]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>

    Nov 07 08:44:51 CoreELEC librespot[18079]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>

    Nov 07 08:44:55 CoreELEC systemd[1]: Stopping librespot...

    Nov 07 08:44:55 CoreELEC systemd[1]: Stopped librespot.

    Nov 07 08:45:00 CoreELEC systemd[1]: Started librespot.

    Nov 07 08:45:00 CoreELEC sh[18102]: INFO:librespot: librespot 582a7b5 (2018-10-04). Built on 2018-10-04. Build ID: 4eE7k6KS

    Nov 07 08:45:00 CoreELEC sh[18102]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:45:00 CoreELEC librespot[18123]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:45:00 CoreELEC sh[18102]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:45:00 CoreELEC librespot[18123]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:45:00 CoreELEC sh[18102]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>

    Nov 07 08:45:00 CoreELEC librespot[18123]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>

    Nov 07 08:45:10 CoreELEC systemd[1]: Stopping librespot...

    Nov 07 08:45:10 CoreELEC systemd[1]: Stopped librespot.

    Nov 07 08:45:11 CoreELEC systemd[1]: Started librespot.

    Nov 07 08:45:11 CoreELEC sh[18165]: INFO:librespot: librespot eb5f246 (2018-10-24). Built on 2018-10-25. Build ID: AoGSVp99

    Nov 07 08:45:11 CoreELEC sh[18165]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:45:11 CoreELEC librespot[18183]: *** WARNING *** The program 'librespot' uses the Apple Bonjour compatibility layer of Avahi.

    Nov 07 08:45:11 CoreELEC librespot[18183]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:45:11 CoreELEC sh[18165]: *** WARNING *** Please fix your application to use the native API of Avahi!

    Nov 07 08:45:11 CoreELEC sh[18165]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>

    Nov 07 08:45:11 CoreELEC librespot[18183]: *** WARNING *** For more information see <Avahi Gains Compatibility Layers for Apple Bonjour and HOWL>


    PS: But now, after removing my Spotify credentials, it's working!

    Then try systemctl start service.librespot

    Hey man,


    After typing systemctl start service.librespot I typed journalctl -u service.librespot and this is what I have:



    -- Logs begin at Tue 2018-11-06 18:28:51 -02, end at Tue 2018-11-06 19:31:43 -02. --

    Nov 06 19:29:56 CoreELEC systemd[1]: Started librespot.

    Nov 06 19:29:56 CoreELEC sh[13639]: INFO:librespot: librespot 582a7b5 (2018-10-04). Built on 2018-10-04.

    Nov 06 19:29:57 CoreELEC sh[13639]: INFO:librespot_core::session: Connecting to AP "guc3-accesspoint-b-vg

    Nov 06 19:29:58 CoreELEC sh[13639]: thread 'main' panicked at 'Authentication failed with reason: Premium

    Nov 06 19:29:58 CoreELEC sh[13639]: stack backtrace:

    Nov 06 19:29:58 CoreELEC sh[13639]: 0: 0xab11b393 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 1: 0xab123feb - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 2: 0xab11d6e3 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 3: 0xab11d343 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 4: 0xab11dfa7 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 5: 0xab11dcdf - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 6: 0xab11dc2b - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 7: 0xaadc73df - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 8: 0xaad76ef3 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 9: 0xaadb86a7 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 10: 0xaae158e3 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 11: 0xaacbecb3 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 12: 0xaac9f047 - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 13: 0xaac9f2ab - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 14: 0xaaca654b - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 15: 0xaaca9adf - <unknown>

    Nov 06 19:29:58 CoreELEC sh[13639]: 16: 0xaaca6b47 - <unknown>

    standard input lines 1-23


    That's weird, because I do own a premium account...Maybe I should try it again without choosing to login into my account?

    Ok,


    This is what I have after inputing the second command:


    Failed to start storage-.kodi-addons-service.librespot-system.d-service.librespo t.service.mount: Unit storage-.kodi-addons-service.librespot-system.d-service.li brespot.service.mount not found.

    According to your logs, the addon is installed and the Kodi addon is started.

    The system.d unit should therefore also be enabled and attempt to start.

    Please try again to log into LibreELEC and type journalctl -u service.librespot (exactly like this).

    Hey man,


    I've ctrl+c/ctrl+v it and, again, the result is -- no entries --


    Thanks


    Hey guys,


    So, I'm trying to watch a ripped copy of a DVD here, you know, one of those TS.VOB files with on-screen menu.


    The problem is that its configuration menu is placed right on the bottom of the screen, and I can't navigate there either using keyboard arrows or mousepad (logitech wireless keyboard)


    When I try to use the arrow keys, KODI's videoplayer hijacks them (fast-forward, navigation bar, etc...)....


    When I try to use the mousepad, since the DVD's menu is located on the bottom of the screen, KODI's video player also hijacks it and its auto-hiding navigation bar pops up.


    So, what I'm I supposed to do to navigate through the DVD's menu? This is kind of driving me crazy here.


    Thanks! :)

    Hi,

    Librespot is known to be running on your setup.

    Librespot does not appear on Spotify's device list while Kodi is playing something else. Therefore, make sure that Kodi is not playing anything when you want to use Librespot.

    If that is not the issue, please provide a log (journalctl -u service.librespot)

    That's weird, because it's not working...I've tried everything (restart, reinstall, etc..)


    I don't know how to generate a log, though? Can you point me the way?


    Thanks!

    Hi everyone,


    So, just installed Librespot on my Odroid C2 running the latest CoreElec, and it's not working.


    I mean, the addon is installed but I can't see it on Spotify's devices list.


    Am I missing something?


    Thanks!

    Hey guys,


    I've been trying to install Sickrage/CouchPotato/Transmission from the Thoradia repository zip file available on GitHub, but it's not working.


    Apparently the addons install, but they all have a radioacive symbol showing up as a thumbnail and the run option (gray rocket icon) is grayed out.


    I'm running LibreELEC 8.2.1 on Odroid C2.


    What am I doing wrong? Can you guys help me out, please...I'm new to LibreELEC and Kodi.


    Thanks,


    M.

    Hey guys,


    This is my first post here, so hi there from Brazil! :)


    Well, I'm looking forward to build a media center/server and I'm trying to figure out what's the best cost-benefit of hardware for running LibreElec/Kodi smoothly.


    Any suggestions?


    I'm kindda inclined to choose Raspberry Pi because, well, they're fun, inexpensive and their community is amazing, but I'm worried about performance.


    Also, a huge concern of mine is 5.1 audio passthrough capabilties via HDMI. This seems to be a recurrent problem in a lot of devices, android based or not. For example, I just found out that the Odroid Xu4 is apparently uncapable of 5.1 passthrough via HDMI; There's a ton of people complaining about it on their forum and apparently there's no solution to it.


    Anyway, I'm accepting other suggestions other than SPCs.


    I just want a setup that works smoothly, is natively compatible with my 5.1 home theater system and simple enough to attach a hard drive to it and make it work as a media center on my network.


    Thanks in advance and have a good day,


    M.