[IMX6] Lirc reacts only to second button press

  • I have installed LibreELEC based on an optimized image for IMX6 (HummingBoard Pro) from vpeter. It was built today (r22590-ge44e492, kernel xbian 4.4.y). But the reported error happens also on the official version I had installed before this one (also with kernel xbian 4.4.y).


    The kodi GUI reacts only to each second button press on my MCE remote which uses the GPIO IR Receiver provided by the HummingBoard Pro. On OpenELEC everything worked right. Below is an output of the command irw.

    Code
    1. HTPC:~ # irw
    2. 67 0 KEY_UP devinput
    3. 67 1 KEY_UP devinput
    4. 67 0 KEY_UP_UP devinput
    5. 6c 0 KEY_DOWN devinput
    6. 6c 1 KEY_DOWN devinput
    7. 6c 0 KEY_DOWN_UP devinput
    8. 69 0 KEY_LEFT devinput
    9. 69 1 KEY_LEFT devinput
    10. 69 0 KEY_LEFT_UP devinput


    The first press was to "arrow up" but nothing happend. The second one was also to "arrow up" and it resulted in the lines 1-3. After that I've pressed "arrow down". Again nothing happened but after the second press to "arrow down" the lines 5-6 appeared.
    Another test was the "arrow right" but this time I've pressend the "arrow left" on the second try. Lines 7-9 appear and as you can see it totally messed up the first press as "arrow right" is completely ignored.
    I do not have another IR remote here to test.



    Do you need any other informations / logs?

    Edited once, last by fanste ().

  • I've upgraded to the latest version from the download section, but it is the same behavior. No ideas whats going on?