LibreElec 8+ Tvheadend Tuner card Issues

  • I have spent many many hours fiddling about with various versions of LibreElec and trying getting my tuner card to work. Since upgrading to 8.0, or 8.01, 8.02 or the beta 8.1.12 etc I can’t get my tuner card to work 100%.


    I have tried all version of LibreElec 8, including fresh installs every time to eliminate any other variables. In versions 8.0, 8.01, 8.02 the adaptor does not appear in TV Adaptor configuration in Tvheadend. In version 8.1 and 8.1.2 (latest beta), the adaptor appears, but none of the muxes work. Scanning just fails.


    I have a NUC and a Hauppauge 930c USB tuner.


    I am based in NZ and use DVB-T. I have tried manual setting for networks and muxes as well as present ones available for New Zealand.


    The card worked flawlessly with both LibreElec (and OpenElec) versions of 7ish.


    The curious thing is that after many hours of research I have stumbled across a few posts online that claim that the 930c (2040:B131 ) is not supported in Linux / LibreElec. However that doesn’t explain how it worked flawlessly and on first attempt when I initially bought it and installed it in LibreElec 7ish with Kodi Jarvis.


    I have limited Linux SSH knowhow… Logic would say that this is simply a driver / firmware issue.


    Thought I would post before I finally give up and kick the Hauppauge 930c to the curb and buy another. We have limited options for USB tuners cards in NZ. Possibly due to the tv network and subsequent compatibility. The only one I have been able to find that is available at the time of writing is an avermedia A867.

  • Ok thanks... here is paste:

    okay just a missing fw


    mkdir -p /storage/.config/firmware

    cd /storage/.config/firmware

    wget -O dvb-demod-si2165.fw https://github.com/CvH/dvb-firmware/raw/aug17/firmware/dvb-demod-si2165.fw

    reboot

    could you try if this is already enough to make it work ? if yes I would change it that it works out of the box with the next release

  • Thanks for that... Those commands didn't seem to change the muxes or the adaptor. However, updating using LE8 Image without media-build as recommended by smp did work. Amazing... back in business.


    I don't know how many other people have this card as there was limited info through forums here and elsewhere. I can provide another dmesg if that is useful for future releases.


    All service, muxes and networks are working correctly now.