Boblight and suspend

  • Hi!

    Used to run Openelec, and had the Boblight addons running for my Lightpack. Everything worked well. About a year ago, I upgraded to Libreelec, still Lightpack worked OK. Then recently, I had some issues with other addons that I could not seem to solve, so I did a wipe, and set it up from scratch, re-installing all addons.

    After re-installing Boblight addons for my Lightpack, I noticed that when doing suspend, the Lightpack would stay on.

    After googling for a while, I found this script that would supposedly fix the issue: OpenELEC Mediacenter - OpenELEC Forum - Turn off Boblight at suspend? (1/1)

    Problem now is that every other time, it turns off Lightpack as intended, and every other time, Lightpack will stay on while suspended.
    Any ideas on how I can modify the script, or do something else to consistently get my Lightpack to turn off when doing suspend?

    I have noticed that when I get the message "failed to connect to boblightd" is when it will not turn off.


    Running Libreelec on an Asus Chromebox-M004U (Haswell/CN60/Celeron2955U)(Chromebox - Official Kodi Wiki)

    Libreelec 8.0.2

    Kodi 17.3

    Lightpack (Lightpack-docs/ at master · Atarity/Lightpack-docs · GitHub)

    Kodi Boblight 2.0.18 by Bobo1on1/Memphiz ([RELEASE] Official XBMC boblight Addon)

    Boblight 8.1.100 by


    Edited once, last by odinb ().

  • How does one get started with Hyperion? Any idea on how to convert existing configuration into hyperion configuration?

    For starters, I have no idea what to choose for HW type, since I have a Lightpack clone.

  • from le side just install the addon and start hypercon, how to configure pls google "hyperion lightpack"

    a convert of the config is not possible

  • Took me a while to figure out the hyperion configuration, seems configuration changes did not always take immediately, but reboot and/or unplugging of USB was needed!

    Definitely much better configuration possibilities once set up!
    Even though my Lightpack has 90 LEDs (10 strips with 9 LEDs on each) and 30 channels, it is still configured as "LED count: 10".

    However, it does not solve my initial problem, it does not turn off the LEDs when I hit suspend. How do you get it to turn off the LEDs when going into suspend?

  • Tried writing a suspend/resume script (Creating Suspend and Resume Scripts - LibreELEC), but cannot get it to work!

    The script wil do the "pre" part just fine when doing suspend, so the lights go out. The "post" part works when I run it from command line (./01-Hyperion.power post), but not when I do the actual suspend/resume. Tried spawning it with:

    (/storage/hyperion/bin/ /storage/.config/hyperion.config.json </dev/null >/dev/null 2>&1 &)

    but still no go!

    Have used suspend/resume scripts before with libreelec, but then it was a service, so I created a service script:

    Description=Hyperion Daemon for Lightpack
    ExecStart=/storage/hyperion/bin/ /storage/.config/hyperion.config.json

    but I cannot save it as "/usr/lib/systemd/system/hyperion.service", since I get the error "/usr/lib/systemd/system/hyperion.service' Read-only file system".

    Any ideas on how I can get either to work?

    Edited once, last by odinb ().

  • not tested

    case "$1" in
    systemctl stop service.hyperion.service
    systemctl start service.hyperion.service

    the /storage/hyperion/bin/ /storage/.config/hyperion.config.json </dev/null >/dev/null 2>&1 & part is from the official hyperion installer - that fu up the whole system -> can't work ;D

  • because they had no understanding of LE/OE and installed their version bypass every system function in LE (complete mess)

    thats why we made an proper version, they not even using systemd so they are not aware of anything what the system is doing

  • Wow, yeah, totally missed that part, did not realize LE had its own branch! Was wondering about the missing service for systemd! I am now running the "hypercon-LE" version, and it works as intended now! Had to add the sleep.d script for the service, but otherwise, it pretty much worked out of the box!