Color problem with S905X

  • Hello,


    I have kszaq's 8.0.2a installed in a Nexbox A95X. The proble is that sometimes it change the TV color:


    xkqalx.jpg


    Then it comes well or just stop and play the play back came ok:


    2f08xs1.jpg


    Could I add some logs? how could I get them?


    Thanks for your help.


    Kind regards.

  • Hello,


    I update to 8.1.2 and I have same color issue.


    The problem is that it does not exist the "output_rgb" file:


    Code
    # ls -l /sys/class/amhdmitx/amhdmitx0/ | pastebinit 
    http://sprunge.us/AFPX


    Best regards.

  • The latest libreelec versions use a new kernel, and the setting command changed - but as I and others have already reported, it currently does not work.

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • The latest libreelec versions use a new kernel, and the setting command changed - but as I and others have already reported, it currently does not work.

    Thanks mmpp,


    Where did you reported?


    Kind regards.

  • You can click on any user icon and see all their posts and likes. We discussed it here: [8.1.2] LibreELEC 8.2 for S905/S905X

    Wetek Hub: LibreElec 8.2.3.1 (Philips 42PFL8404)
    MK808B+: LibreElec 7.0.2.7 (Samsung UE55H6270)
    OTT MXQ Pro 4k (S905): LibreElec 7.0.3.12k (Denon X1200W, 7.1, LG PF1500G)
    AKASO HM8 (S905X): CoreElec 9.0 dev build, Acer Revo 3610: Milhouse test

  • Hello,


    I try both command and no one works:


    Code
    echo 1 > /sys/class/amhdmitx/amhdmitx0/output_rgb
    echo "rgb,8bit" > /sys/class/amhdmitx/amhdmitx0/attr


    Hope this will be fixed soon.


    Regards.

  • 8.1.5 has unmodified Amlogic color space handling.


    Please first try echo "rgb,8bit" > /sys/class/amhdmitx/amhdmitx0/attr

    If this doesn't work try echo "rgb,10bit" > /sys/class/amhdmitx/amhdmitx0/attr


    Remember that you have to switch screen resolution after issuing this command. One way to do this is to issue these commands (together): DM=$(cat /sys/class/display/mode) ; echo null > /sys/class/display/mode ; echo $DM > /sys/class/display/mode